On Sunday 22 February 2004 09:16 am, Noah wrote:
> FreeBSD 4.8-stable
>
> still getting used to installing X applications here:
>
> xsnow is not building from /usr/ports
>
>
> # make install clean                       [/usr/ports/x11/xsnow]
> ===>  Vulnerability check disabled
>
> >> xsnow-1.42.tar.gz doesn't seem to exist in /usr/ports/distfiles/.
> >> Attempting to fetch from http://www.euronet.nl/~rja/Xsnow/.
>
> Receiving xsnow-1.42.tar.gz (56752 bytes): 100%
> 56752 bytes transferred in 19.6 seconds (2.83 kBps)
> ===>  Extracting for xsnow-1.42
>
> >> Checksum OK for xsnow-1.42.tar.gz.
>
> ===>  Patching for xsnow-1.42
> ===>   xsnow-1.42 depends on file: /usr/X11R6/lib/X11/config/date.def
> - found ===>   xsnow-1.42 depends on shared library: X11.6 - found
> ===>  Configuring for xsnow-1.42
> env: xmkmf: No such file or directory
> *** Error code 127
>
>
> --- snip ---
>
> % pkg_info | grep XFree86                                       [~]
> XFree86-3.3.6_11    X11R6.3/XFree86 core distribution
> XFree86-font100dpi-4.2.0 XFree86-4 bitmap 100 dpi fonts
> XFree86-font75dpi-4.2.0 XFree86-4 bitmap 75 dpi fonts
> XFree86-fontCyrillic-4.2.0 XFree86-4 Cyrillic Fonts
> XFree86-fontDefaultBitmaps-4.2.0 XFree86-4 default bitmap fonts
> XFree86-fontEncodings-4.2.0 XFree86-4 font encoding files
> XFree86-fontScalable-4.2.0 XFree86-4 Scalable font files
> imake-4.2.0_1       Imake and other utilities from XFree86
> imake-4.3.0         Imake and other utilities from XFree86
>
> --- snip ---
>
> any clues here?

You have a mixed combo. You have part of 3.3.6 installed and 4.2. You 
need a clean XFree86-4 for anything to work. Do you have an 
"XFREE86_VERSION" in your /etc/make.conf. I can't think of anyway you 
would have both 3.3.6 and 4.2 installed unless you did.

It also sounds like you might have an out of date port system. At this 
point, you might as well upgrade to version XFree86-4.3.0. I would 
think about getting a working 4.2 before updating. There are some 
problems with make on the older systems. Port maintainers are using new 
make options that don't work on the pre-4.9 systems. 

A current 4.9-stable will be different than what you are using now.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to