On Sunday,  8 February 2004 at 21:43:19 +1030, Michael Ritchie wrote:
> I have followed the method advocated by Drew Tomlinson on this list
> (October 2002) to create a Vinum volume without losing data.  Everything
> worked ok for the first drive... and then I added the second, and grew
> the file system using growfs ... and then added the third subdisk to the
> plex, and tried to growfs again, and got the following message:
>
> # growfs -N /dev/vinum/data
> new file systemsize is: 195366077 frags
> Warning: 157556 sector(s) cannot be allocated.
> growfs: 381497.4MB (781306752 sectors) block size 16384, fragment size 2048
>        using 2076 cylinder groups of 183.77MB, 11761 blks, 23552 inodes.
>        with soft updates
> super-block backups (for fsck -b #) at:
> ...
> growfs: bad inode number 1 to ginode
>
> ...
>
> I'm running 5.2-RELEASE, with kernel compiled from RELEASE source to
> include IPFW.  Fairly standard stuff.  Is something broken or am I
> doing something wrong??

Sorry about the late response; I appear to have overlooked this issue.

What file system?  UFS 1 or UFS 2?  growfs is suffering a bit from
lack of love at the moment.  It might be worth putting in a PR.

Greg
--
When replying to this message, please copy the original recipients.
If you don't, I may ignore the reply or reply to the original recipients.
For more information, see http://www.lemis.com/questions.html
Note: I discard all HTML mail unseen.
Finger [EMAIL PROTECTED] for PGP public key.
See complete headers for address and phone numbers.

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to