Roman Bogorodskiy wrote:
Hi,
        
        As described in
http://www.freshports.org/[EMAIL PROTECTED],
I've reinstalled portupgrade-\*.

And now when I try to run portupgrade I have such error:
        
novel /usr/local/bin $> portupgrade -sfr lang/ruby16
--->  [Executing a command as root: sudo /usr/local/sbin/pkgdb -u]
--->  Updating the pkgdb
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 266
packages found (-41 +135) (...)ruby in malloc(): error: allocation
failed
--->  [Executing a command as root: sudo /usr/local/sbin/pkgdb -u]
--->  Updating the pkgdb
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 266
packages found (-41 +135) (...)ruby in malloc(): error: allocation
failed
The pkgdb must be updated.  Please run 'pkgdb -u' as root.
novel /usr/local/bin $>

What's wrong?

FreeBSD 5.2.1-RELEASE i386
portupgrade 1.8.1
ruby 1.8.1 (2003-12-25) [i386-freebsd5]

I think this is because ruby-1.6 used to install /usr/local/bin/ruby, but by the recent upgrade this becomes /usr/local/bin/ruby16 and ruby is not there anymore. Since portupgrade needs ruby, portupgrade gets stuck as soon as upgrading ruby-1.6 removes the /usr/local/bin/ruby file.

I have removed portupgrade and all related ruby stuff and then reinstalled
portupgrade, which then installs ruby-1.8. All works well then.

Rob.
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to