i was thinking about setting up an online learning environment for some
students here and remembered moodle.


i did a #make search name=moodle on my ports and couldn't find anything. now, has anyone tried this? im not familiar enough with freebsd and/or
the ports to know whether it is safe to install this on my system so i
just wanna ask around first...

Well, to answer your subject: no, haven't tried it. I used to be a teacher, though...I'll wish you luck. A brief browse of the url you provided yields this information:

Moodle is a web-based application, written with
PHP and a database backend (MySql, PostGreSQL).
As for security, it's not *real* likely that these guys
have done anything on purpose to threaten your

A harder issue would be whether or not the PHP
scripts have been written securely, and that's a
subject for another forum.  I like PHPBuilder.com
for PHP issues.  I would be sure and check whether
or not they are using a lot of system-type calls
(shell_exec(), system(), passthru(), etc.) or whether
the application is more self-contained.  Also, whether
or not the PHP engine must be run without safe_mode
might be something to think about.

If you can run a webserver with PHP and a database,
you will be able to use Moodle.  It hasn't been ported
to FreeBSD, probably, because of one of the following
(which are all speculations....) :

a.  it's new?  Can't tell...
b.  Nobody wanted to port it (seems likely ... need a hobby?) ;-)
c.  It doesn't really *need* to be ported, as it's just a set
         of web server scripts.
d.  Kris Kennaway doesn't want another blasted
           port/maintainer to deal with...
**Joking, joking!!! We luv Kris and the whole FBSD team!!!! ;-) **

another thing, they had instructions for getting it via CVS:

From a Unix computer
To connect and login for the first time to the CVS server, you can use
this command:

cvs -d:pserver:[EMAIL PROTECTED]:/cvsroot/moodle login

There is no password - when asked for one, just hit Enter.

To checkout (download) the entire Moodle code for the first time, use this

cvs -z3 -d:pserver:[EMAIL PROTECTED]:/cvsroot/moodle co moodle

anyway i tried this but it went like:

su-2.05b# cvs -d:pserver:[EMAIL PROTECTED]:/cvsroot/moodle login
Logging in to :pserver:[EMAIL PROTECTED]:2401/cvsroot/moodle
CVS password:
cvs [login aborted]: reading from server: Connection reset by peer

What does that mean?  Any ideas on how to fix this?  Although i could just
upload the tar file from my windows box, i am curious about this.


Hmm, anonymous CVS asking for a pw?  I do know
that the sourceforge *developer* cvs system has been
having problems with LDAP not adding passwords for
developers properly.  A workaround for that is to simply
re-add your password using their interface.  But, I don't
think that's going to help in your case.

I'm guessing that it's a problem on their end, or
something in your environment asking their server
for a login prompt.  I'm not that good with CVS, so
I probably can't help you there.  However, I can say
that it worked for me just a moment ago....

Are you not running a GUI on FreeBSD?
You can grab the tarball from a browser, or
note the URL and grab it from the CLI with
fetch(1) or wget(1) or the like.  I'm doubting
that a PHP project would take very long to
get even on a slow modem.  (hmm, except
the pix...and the compatibility programs....
this is looking rather interesting.)  OK, the
new release BETA is 2X the size of the older
one... hmm, I'd not cvs this one probably;
although I guess the good news would be
that you could keep up easily once you'd done
it once.

I'll wish you good luck ... and like I said,
checkout PHPBuilder.com; it's a nice community
there, as well, much like FreeBSD, only younger
(maybe) and they don't all type as well...  :-D
I've gone on long enough.  HAND!


Kevin Kinsey
DaleCo, S.P.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to