I have a system running four jails. MySQL is running in two of the jails and I
am trying to add it to a 3rd jail. Starting the server gets the message:

  040302 19:34:15  mysql started
  040302 19:34:15  Can't start server : Bind on unix socket: Permission denied
  040302 19:34:15  Do you already have another mysqld server running on socket:
                   /tmp/mysql.sock ?
  040302 19:34:15  Aborting
  040302 19:34:15  /usr/local/libexec/mysqld: Shutdown Complete
  040302 19:34:15  mysqld ended

The new jail was created by copying the file tree from a jail that had the
desired configuration and then doing clean-up as required. In response to the
error I tried configuring mysqld to use a different port and socket file. That
did not fix the problem. I had forgotten the other two mysql's are using port
3306 and /tmp/mysql.sock.

I next removed mysql and its dependencies and reinstalled mysql-server-4.0.16
using pkg_add. I am still getting the same error. At this point I think it is a
jail problem with something I missed in clean-up but I do not know where to look

Having done all this, I recalled in installing the 2nd MySQL jail, it was
necessary to remove and reinstall mysql. In that instance the re-installation
solved the problem.

Thanks for any ideas.

Douglas Denault
Voice: 301-469-8766
  Fax: 301-469-0601
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to