On Sun, Mar 07, 2004 at 07:29:09AM -0500, Chris Demers wrote:

> I have been having a problem trying to get CVSUP working correctly on a SUN
> ULTRA 10 (256MB 40GB HDD) with CURRENT, i can ftp in the sources and do full
> build worlds and kernel without any problems, but even after i blow away all
> the src, ports, and sup, directories and it start recreating them when i run
> CVSUP it gets stuck and has a weird retry time.   Any suggestions?  I have
> tried over a dozen other CVSUP servers with the same exact results.  Even
> using my own local one on my network does the same thing.  Only way i  have
> been able to get sources back into the machine is to FTP them in from a snap
> server.  Any suggestions would be apprechiated.  Note, other machines on the
> exact same network segment have absolutely no problems using CVSUP.

Hmmm... looks like you've found a bug, probably.  All you're seeing is
your machine failing to connect to the cvsup server: the 'reconnect'
message is entirely normal for that circumstance. Can you confirm that
you can connect to the cvsup port on any of the cvsup servers you're
using via telnet?

    % telnet cvsup.example.com 5999

You should be able to see the banner that cvsupd produces - something like:

    OK 17 0 SNAP_16_1f CVSup server ready

If not, then you need to work out what's wrong with the
networking/firewalling setup on your Ultra10.

If you can connect, then there is clearly a bug in the version of
cvsup you're using on that machine.  You should report what you're
seeing to the port maintainer, John Polstra, (who also happens to be
the author of cvsup) according to the instructions at
http://www.cvsup.org/faq.html#bugreports -- in this case, as well as
providing the data asked for there, a network dump of the traffic
between your machine and the server would probably be useful too:

    # tcpdump -i fxp0 -w /tmp/cvsup-session.out port 5999

(replace 'fxp0' with the name of your principal ethernet interface)
and then in another window, run your cvsup command:

    # cvsup -g -L 2 supfile

Kill the cvsup session after it says "Will retry", and then kill the
tcpdump process.  If the cvsup-session.out file isn't too large, then
you can uuencode it and include it in your bug report (together with
the commands used to generate it), otherwise just mention that it is
available if required.

Be prepared to receive patches and apply them to the cvsup sources and
recompile and run whatever tests John may request.

        Cheers,

        Matthew

-- 
Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to