Example of a test of this method (running burncd at low speed to make sure tar+gzip can keep up):

# tar -czf - temp/* | burncd -f /dev/acd0c -s 2 data - fixate
next writeable LBA 0
writing from stdin
written this track 3760 KB total 3760 KB
fixating CD, please wait..
# mkdir temptemp
# cd temptemp
# tar -xzf /dev/acd0c

gzip: stdin: decompression OK, trailing garbage ignored
tar: Child returned status 2
tar: Error exit delayed from previous errors

thanks. i tried that exactly.
i still get unexpected eof, whether i pipe tar to burncd
or just burncd the tar.gz file, i get similar errors:

gzip: stdin: unexpected end of file
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

All of the unpacked files were identical to the originals according to diff. The error message seems to indicate that tar pads blocks at the ends of files with characters that confuse gzip.

I also did a test that produced 148 MB of tar.gz file, and it unpacked fine (with the same error message).

maybe it's gzip.  i've got 1.2.4
i'll try tar alone and see what happens.
thanks, Bob.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to