On Sat, Mar 13, 2004 at 02:13:26AM -0600, Hermes Trismegistus wrote:
> This request is much a cry in desperation. I have tried everything
> possible, at least, everything I know to do. I have sent inquiries to the
> ports list, none can solve it.

Usually such problems are temporary glitches caused by mistakes in
ports Makefiles or commits to ports being caught at just the wrong
moment when you do your cvsup(1).  The vast majority of the time, the
solution is simply to go away for a few hours and then try again.
 
> After I run my cvsup on my ports, I get this kind of stderr at the CLI
> when I run the "portsdb -Uu":

Another standard response is that if 'portsdb -Uu' doesn't work, then
try 'make index' instead.  It used to be the portsdb worked better,
but honours have oscillated between the two over the last few years.
At the moment, I'd say that 'make index' has the advantage, especially
since the commits Kris made recently that knocked about 30% off the
execution time.
 
> --------------just a small snip of the errors------------------
> make_index: ifm-4.1_2: no entry for /usr/ports/x11-toolkits/tk84
> make_index: gnomeblog-0.7_1: no entry for /usr/ports/x11-toolkits/py-gtk2
> make_index: gnomeblog-0.7_1: no entry for
> /usr/ports/x11/XFree86-4-libraries
> make_index: gnomeblog-0.7_1: no entry for /usr/ports/misc/gnomehier
> make_index: gnomeblog-0.7_1: no entry for /usr/ports/x11-toolkits/py-gtk2
> make_index: gnomeblog-0.7_1: no entry for
> /usr/ports/x11/XFree86-4-libraries
> Warning: Duplicate INDEX entry: *** Error code 1
> Warning: Duplicate INDEX entry:
> -----------------------------------------------------------------

Making INDEX successfully generally requires that you pull down a full
copy of the ports tree: if you refuse, say, the foreign language ports
there's no guarrantee that there won't be other ports in the system
that depend on those ports.  And a missing dependency like that is a
prime cause of the sort of breakage you're seeing.  Check your
/usr/sup/refuse file carefully.

The 'Duplicate INDEX entry' response happens when the
/usr/ports/Tools/portbuild/scripts/makeindex script trips over an
error in the output of the 'make describe' target -- usually it's
trying to parse a couple of blank lines.  A good way to fix such
problems is to run 'make describe' from /usr/ports, look at any error
messages to pick out the individual ports that are causing problems,
and in your case, delete those ports and then re-cvsup to get a clean
copy.  Usually the instruction would be to "fix whatever is wrong with
the port", but that's directed more at ports committers rather than
general users.  Whatever you do: lather, rinse and repeat until you
can build the INDEX cleanly.

        Cheers,

        Matthew

-- 
Dr Matthew J Seaman MA, D.Phil.                       26 The Paddocks
                                                      Savill Way
PGP: http://www.infracaninophile.co.uk/pgpkey         Marlow
Tel: +44 1628 476614                                  Bucks., SL7 1TH UK

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to