Hello all, I'm trying to use FreeBSD 5.2.1 in my computer behind a 
domestic ADSL modem-router. At home, we have 2 computers, 1 is a server 
and the router uses NAT with some port redirections; and the 2nd one is 
my workstation, where I use NetBSD, Linux and FreeBSD 5.2.1.

   The problem is the next (and it is very very weird):

        a) When I installed FreeBSD 5.2.1; i also installed cvsup-without-gui
        (latest version) and I tried to update my src and my ports, but the
        program was stopped at these lines:

        Establesing multiplexed-mode

        That's all, I couldn't download any delta.

        b) If I try to use traditional CVS, I can use cvs checkout to download 
        the entire source tree, or even ports tree. But, once I have got all the
        tree, if I go into the tree (both src and ports) and I try to cvs update,
        the program is stopped at the beginning and it doesn't download anything.

        c) Even all, I played with cvsup -P port (openning that port in my 
        firewall), -P - (for passive connections as CVS uses), -P a, and -P m.
        But none above worked, so I'm frustrated.

        The very very weird thing is that I said, I yes can download trough
        'cvs co src'; but once I've got all the src tree, if I get into and I
        try: 'cvs update'; the cvs establishes the both passive connections with 
        the server but nothing is downloaded; and I get a Timed Out Connection
        in about 10 minutes.

   I can use deltas because I use normal FTP connections, but I prefer 
pretty much the cvsup due to confortability and ease.

   These problems didn't happen with FreeBSD 4.7-RELEASE nor 4.8-RELEASE, 
but yes with 5.X branches. I use FreeBSD since 2 years ago and I'm sure 
there's no errors in supfiles even I used CVS and it is not working.

   Can anyone help me please?

        P.S.- I was reading a lot of mails about problems with cvsup behind
        firewall, but all people solved them openning any port in firewall and
        then using -P port with cvsup. But it doesn't works for me, I open the
        port but the server doesn't connect back to me (using above port).
/*** mkd ***/

Claudio M. Camacho

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to