Kirk Strauser <[EMAIL PROTECTED]> wrote: 
At 2004-03-22T20:25:54Z, samy lancher writes:

> Hey,

Quit top posting.

> I did "make uninstall " in usr/ports/databases/mysql323-client. and than i
> gave the command portupgrade -NPRri mod_php4.
> 
> This time, mysql-client-4.0.18_1 was installed and at the end of php
> installation i got the following error:

Did you *want* to upgrade to the MySQL 4 client (instead of the version 3
client that matches your server)?

All i want to do is install mod_php4 in my system. mysql 4 client was installed  
automatically when i used portupgrade. 

> ---> Registering installation for mysql-client-4.0.18_1
> ----> Returning to build of mod_php4.4-3.4_7,1
> Error: shared library "mysqlclient.12" does not exist.

Step one: Pick a version of MySQL, and make sure that your client and server
are both at that version.

Does mysql-server and mysql-client should have the same version?. Since Mod_php4 has 
mysql-client as dependency, portupgrade has upgraded mysql-client to necessary version 
and did not touch mysql-server. Now, my question is: does making mysql-client and 
mysql-server to same version would really  help in installing mod_php4?

Thanks,

Naveen.

Step two: Try that portupgrade again.
-- 
Kirk Strauser

"94 outdated ports on the box,
94 outdated ports.
Portupgrade one, an hour 'til done,
82 outdated ports on the box."


> ATTACHMENT part 2 application/pgp-signature 




Do you Yahoo!?
Yahoo! Finance Tax Center - File online. File on time.
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to