Adam Bozanich wrote:

Hi all.

I am trying to get the gaim port to work. If I build with:

make WITHOUT_NSS=1

everything is fine, but I can't connect to msn.  If I don't send any
arguments to make, when I run gaim, I get:

Fatal error 'Spinlock called when not threaded.' at line 83 in file
/mnt/s10/BSD/usr_src/lib/libpthread/thread/thr_spinlock.c (errno = 0)
zsh: abort      gaim

This has been happening for a couple of weeks, and I was hoping that
it would be fixed.  Now I'm wondering if my system is the problem.

Here's my kernel config. Am I missing something?



Hey Adam,


I fought with this for about three hours the other night. Go to Gaim's faq-ssl:

http://gaim.sourceforge.net/faq-ssl.php

I used the GnuTLS tools.

libgpg-error (needed by libgcrypt): ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-0.5.tar.gz

libgcrypt (needed by GnuTLS): ftp://ftp.gnupg.org/gcrypt/alpha/libgcrypt/libgcrypt-1.1.43.tar.gz

libtasn1 (needed by GnuTLS): ftp://ftp.gnutls.org/pub/gnutls/libtasn1/libtasn1-0.2.6.tar.gz

GnuTLS (needed by gaim): ftp://ftp.gnutls.org/pub/gnutls/attic/gnutls-0.9.91.tar.gz

As the page says, instal them in that order. After doing so, download the latest source for Gaim .075. Unpack it and then do a "./configure --with-gnutls-includes=PREFIX (Location of GNUTLS includes.)
--with-gnutls-libs=PREFIX (Location of GNUTLS libraries.)"



eg.. Mine looked like this:


"./configure --disable-nls --disable-perl --with-gnutls-includes=/usr/local/lib/ --with-gnutls-libs=/usr/local/lib/"

I only know English so, --disable-nls and for some reason I can't get perl to compile with it so, --disable-perl.

Everything worked fine after that. Hope this helps you.

Michael

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to