Matthew Seaman wrote:
On Thu, Mar 25, 2004 at 02:27:02PM +0100, Heinrich Rebehn wrote:

I tried substituting libc_r with libkse (there is no libpthread on 5.2.1-RELEASE-p3). Still no good. httpd dumps core. :-(

Yes. I now have heard that the new threading libraries have been
deemed good enough to be made part of the system, so libc_r is the
place for all threaded programs to link against, and the libkse and
libpthread stuff is basically obsolete.

I did an lsof for the httpd process (with php4 commented out) and it shows no sign of any two modules using different threading libraries:

So the core dump is only happening when mod_php is enabled?  Do you
have the command line version of php installed (you get this with
lang/php4, but not www/mod_php4), and does the crash still happen with
that?  If so, try:

    % /usr/local/bin/php << E_O_F
    ? <? phpinfo() ?>
    ? E_O_F

(The ? at the start of those lines is a shell prompt, which might
appear as > in some shell.  Either way, don't type that character.)

That should print out a large amount of information about your PHP setup.

You can view it at

Hmmm... Probably the next thing to try is simply rebuilding the mod_php4 port. I'm fairly certain there is some sort of shlib conflict or missing shlib which is making everything fall over. Try only enabling the minimum number of options you can in the PHP config.

I will try that. Thanks for your help, Heinrich _______________________________________________ [EMAIL PROTECTED] mailing list To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to