On Monday 29 March 2004 12:03 pm, Bart Silverstrim wrote:
> I recently ran a portupgrade on one of our servers.  The following
> error and exchange came up:
>
> server# pkgdb -F
> --->  Checking the package registry database
> Stale dependency: portupgrade-20040325_1 -> openssl-0.9.7d
> (security/openssl):
> New dependency? (? to help): ?
>   [Enter] to skip, [Ctrl]+[D] to delete,  [.][Enter] to abort, [Tab]
> to complete
> New dependency? (? to help):  portupgrade-20040325_1
> Fixed. (-> portupgrade-20040325_1)
> Cyclic dependencies: portupgrade-20040325_1 ->
> (portupgrade-20040325_1) Unlink portupgrade-20040325_1 ->
> portupgrade-20040325_1 ? [yes] Command failed [exit code 1]: "grep -v
> \"^portupgrade\\\\-20040325_1\\\$\" <
> /var/db/pkg/portupgrade-20040325_1/+REQUIRED_BY >
> /tmp/+REQUIRED_BY82988.0"
> server#
>
> What should I have chosen?  pkgdb -F doesn't find any problems now,
> and no errors that I *see* are coming up, but should I deinstall and
> reinstall portupgrade or have I done something wrong to the database?
> How can I fix it?

It was complaining because you didn have openssl installed, so you need 
to install openssl-0.9.7d and link portupgrade to it. It is probably 
faster to just portupgrade portupgrade again but things can go 
wrong :).

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to