Babbling Blatherscythe! Chris Meyers <mailto:[EMAIL PROTECTED]> had
this to say:

> I am trying to build java/jdk14 with portupgrade, and I have run into
> a problem. After downloading all the necessary patches and the j2sdk
> binaries and src files from Sun, I ran the following:  
> portupgrade --new java/jdk14
> Things went along fine for about 2 hours, and then wham I get the
> following error: 
> Java HotSpot(TM) Client VM warning: Can't detect initial thread stack
> location
>                                        'class' or 'interface'
> expected Java HotSpot(TM) Client VM warning: Can't detect initial
> thread stack location ^
> unclosed character literal Java HotSpot(TM) Client VM warning: Can't
> detect initial thread stack location ^ 2 errors    
> gmake[4]: *** [.compile.classlist] Error 1
> gmake[4]: Leaving directory
> `/usr/ports/java/jdk14/work/j2se/make/java/java' 
> gmake[3]: *** [optimized] Error 2
> gmake[3]: Leaving directory
> `/usr/ports/java/jdk14/work/j2se/make/java/java' 
> gmake[2]: *** [all] Error 1
> gmake[2]: Leaving directory
> `/usr/ports/java/jdk14/work/j2se/make/java' 
> gmake[1]: *** [all] Error 1
> gmake[1]: Leaving directory `/usr/ports/java/jdk14/work/j2se/make'
> gmake: *** [j2se-build] Error 2
> *** Error code 2
> Stop in /usr/ports/java/jdk14.
> ** Command failed [exit code 1]: /usr/bin/script -qa
> /tmp/portupgrade8248.0 make 
> ** Fix the problem and try again.
> ** The following packages were not installed or upgraded (*:skipped /
> !:failed)
>         ! java/jdk14    (unknown build error)
> I did some searching and noticed that someone else posted the exact
> same problem a couple weeks ago, but unfortunately no one replied to
> his problem.  
> Has anyone solved this, or know what I should do to fix the problem?
> Here's some more info that may be helpful: 
> port: jdk-1.4.2p6_4
> uname -mp: 5.1-RELEASE-p2 i386
> Thanks for any help,
> Chris
> p.s. sorry for the long lines in the error

I know it flies by rather quickly, but paying attention while the
Makefile flies by never hurts.

 -- To build JDK 1.4.2 port, you should have linux emulation
 -- enabled in the kernel and linux procfs (linprocfs) filesystem
 -- mounted.

I had a failure in just about the same spot, if I recall correctly. Sun
has a linux release for the jdk, but no FreeBSD release. In order to
build a native compile of the jdk on FreeBSD, the linux build is used to
compile it. Hence, linux emulation is require for the build phase. You
can go ahead and remove the linux emulation ports after you're done with
the build if you like.

Part of the build process from new I believe installs the necessaru
linuxbase port, if they're not there already. What it doesn't do is load
the kernel module and mount the linprocfs filesystem for you - which is
where my failure happened, and probably yours as well.

So... Granted that you have the linux ports installed (pkg_info
linux_base, or if you like waiting... portversion | grep linux_base),
load the linprocfs kernel module and mount a linprocfs file system:

kldload linprocfs
mount -t linprocfs linprocfs /compat/linux/proc
(or, add a linprocfs entry with the above mountpoint to your fstab and
do a mount linprocfs)

Now try rebuilding the jdk14 port.

Jason Wilson
Director of Technology
Nobilis Software
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to