Hello,

we've a FreeBSD 5.1 box at a hosting company. As we need a lot more maxsockets and resources, I added the following lines to /boot/loader.conf:

kern.ipc.maxsockets="640000"
kern.maxusers="4096"
kern.ipc.nmbclusters="120000"

Some would say, these are somewhat crazy values for this options, but be sure, we will need them sooner or later, and I only want to reboot once. ;) And I tested them on a local machine here, and it worked.

Then I rebootet. But the box didn't answer anymore after that, so I wrote the support what's up.
Support is: >
Me is: Me


--- Mail exchange begin ---
> I've tried rebooting your machine several times again and tried to enter as Single User Mode. The problem still persist as it reboots
> after this line, "panic: Unable to alloc kernal virtual memory".


Me: I tried to rebuild the same behavior. So I configured a local testserver with the same loader.conf like I did with the server at your
Me: datacenter, but it boots without problems. Only difference is, that my is running 5.2.1 instead of 5.1


> It seems that we can't access your machine to even look at the /boot/loader.conf file.

Me: Hmmm, what would you suggest if we can't get it back? If it gets a new setup, would it be possible to keep the partitions
Me: untouched, so the userdata is still there?


Me: I'm very sorry for the trouble. I didn't update to 5.2.1 to save us such headaches. I'm not sure, but I think I should update it
Me: the next time.


> Unfortunately since we are able to even login as single user mode, we cannot save any data on your box

Me: Sure, but this was not what I meant. I mean: When you make a new install, you've the possibility to use the existing partitions, and
Me: just delete and recreate the / mountpoint. This works easy and it resets the full system, as / will be wiped, but without any user-
Me: data loss, as all other (/usr, /home) remain untouched. I did this several times.


Me: As the partition is aleady there, simply "skip" the Fdisk tool with Q and in the following Disklabel Editor only remove and recreate
Me: the mountpoint that represents /. For the other just set the mount points for each of them with M.
Me: I'm sure you're familiar with your mount points and sizes you give your servers, so you know which one represents /. The /home
Me: is the biggest one with around 60gig, the /usr has around 7gig.


Me: After that he wipes /, checks the other filesystems and installs into a clean /.

Me: I hope this will also help you with further system resets, others could need. ;-) If you've any questions concerning these steps,
Me: let me know. We would have to reupload a lot of data, if all would be blown away and I don't hope it, but something like this
Me: seems to occour somewhat more than once. So this seems to be the more data-friendly way.


Me: But it should also be possible to mount the partitions with the help of some fixsystem (From CD/Network) and to edit /boot/loader.conf

Me: I don't know what's the easier way, so I just ask you what we will do now?
--- Mail exchange end---

In around 3 hours they will be up for support again. Does anyone have any further suggestions, how to get this box back? I searched for this kernel panic message, but didn't find anything that would fit to my changes I did on the /boot/loader.conf

Would you suggest the support to go the "wipe just / and reinstall", or is there an easy way to edit /boot/loader.conf at the current situation?

Greets,
Michael Ritter

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to