On Thursday 01 April 2004 07:05 am, Jesse Sheidlower wrote:
> I'm sure this is a silly question, but. I know about use.perl and
> so forth for the 4.x series.
>
> Yesterday I installed FreeBSD 5.2.1, and the active Perl port
> is /usr/ports/lang/perl, which is v. 5.6.1. I'd like to upgrade
> to 5.8.2, which is in /usr/ports/lang/perl5.8 and thus I can't
> just do "portupgrade perl".
>
> Exactly what do I have to do to accomplish this? "portinstall
> perl5.8" doesn't work ("No such installed package nor such port..."),
> nor does "portinstall perl-5.8.2_2" (which is said to be the
> package name in the README file). The PORTNAME given in the 5.8
> Makefile is just "perl".
>
> I assume I could just do a make install from the perl5.8
> directory, but how do I do it with portupgrade? And then how
> do I get rid of the 5.6 version and rebuild things with 5.8?
>

Follow the instructions in /usr/ports/UPDATING.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to