I wrote:

I can't get the program to link. In the output below, the things that c-client4.a is complaining about are found in the pam and ssl libs earlier in the line (I grep'd for a number of them, in /usr/lib/*.a, and they were found in those two libs). I have tried many different ways of ordering the libs, and this is the one that produces the least undefined references. I have all the libs found in /usr/lib first and the libs from /usr/local/lib second.


I'm pulling my hair out trying to get this to work. Can someone help me figure this out please?

I'm at my wits end with this. I've continued to try reordering the libs or adding them more than once, as 'man ld' says I can do (that only led to even more undefined references), and even tried to tell ld to search the libs multiple times, via the -( -) construct, but make barfed on that.


Any programmers out there that would be able to help me sort this out, off list, please? TIA.

        -ste
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to