On Wed, Apr 07, 2004 at 08:49:06PM -0400, Joe Marcus Clarke wrote:
> On Wed, 2004-04-07 at 19:36, Jesse Sheidlower wrote:
> > 
> > I am, however, having a problem with the login session. When I
> > try to log in, I instantly get an error message with "Your 
> > session only lasted less than 10 seconds"; I can use the Failsafe
> > GNOME session without a problem, and .xsession-errors tells me
> > that 
> > 
> >   /usr/libexec/ld-elf.so.1: Shared object "libutil.so.3" not found
> > 
> > I do have libutil.so.4 installed; is there some different package
> > I need that provides 3? I did reinstall gnomesession, but the
> > result was the same.
> 
> Looks like you installed an out-of-date package.  You'll have to use ldd
> to find the binary linked to libutil.so.3, use pkg_info -W to find out
> which port installs it, then rebuild that port.

Thanks. In the meantime I had discovered that it was "sessreg"
causing the problem, but sessreg wasn't associated with any of
my installed packages (it must have come from my previous
binary install of 4.4, which I thought I had
deleted). Reinstalling XFree86-4-Server-snap did not help, so
I poked around a little more, installed XFree86-4-clients
(which I had previously got along without), and now I seem to
be all set.

I hope this doesn't create problems in the future, but since for now
my package database is happy and X works, so I guess it's OK.

Thank you for your help.

Jesse Sheidlower
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to