I'm still trying to bring the portupgrade process to successful conclusion on 
my 5.2 system. I'm trying to avoid any more "well, let's try this and see 
what happens" experiments as they simply take so long - so I'm asking for 
some directions to help me reach the end from here.

I've completed 'portupgrade -fr gettext'.  At the tail end of that process I 
received a list of ports that were skipped or failed (see below). I'm 
guessing that these exceptions are a result of unsatisfied dependencies, but 
I don't know how to resolve them without (potentially) creating still more 
problems.

Any advice would be appreciated - if there's something I should be reading to 
help sort this out for myself I'd appreciate a pointer... so far I've been 
unable to find any specific advice in the handbook.

Thanks,
Jay

# portupgrade -fr gettext

... finished at approx 10:50 PM CDST, April 8, 2004
the final result was:

[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 224 packages 
found (-0 +1) . done]
--->  Skipping 'x11-toolkits/eel2' (eel2-2.4.1) because 'x11-toolkits/
libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'www/libgtkhtml' (libgtkhtml-2.4.1_1) because 'accessibility/
gail' (gail-1.4.1) failed
--->  Skipping 'www/epiphany' (epiphany-1.0.6) because 'x11-toolkits/
libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'x11/gnomepanel' (gnomepanel-2.4.1) because 'x11/
gnomedesktop' (gnomedesktop-2.4.1.1_1) failed
--->  Skipping 'sysutils/gnomesystemmonitor' (gnomesystemmonitor-2.4.0) 
because 'x11-toolkits/libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'deskutils/gnomeutils2' (gnomeutils2-2.4.1,1) because 'x11/
gnomepanel' (gnomepanel-2.4.1) failed
--->  Skipping 'x11-fm/nautilus2' (nautilus2-2.4.1) because 'x11-toolkits/
eel2' (eel2-2.4.1) failed
--->  Skipping 'sysutils/nautilus-cd-burner' (nautilus-cd-burner-0.5.3_3) 
because 'x11-toolkits/eel2' (eel2-2.4.1) failed
--->  Skipping 'deskutils/gucharmap' (gucharmap-gnome-1.2.0) because 
'x11-toolkits/libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'graphics/eog2' (eog2-2.4.1) because 'x11-toolkits/
eel2' (eel2-2.4.1) failed
--->  Skipping 'graphics/gpdf' (gpdf-0.111) because 'x11-toolkits/
libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'print/ggv2' (ggv2-2.4.0.2) because 'x11-toolkits/
libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'archivers/fileroller' (fileroller-2.4.2_1,1) because 
'x11-toolkits/libbonoboui' (libbonoboui-2.4.1) failed
--->  Skipping 'sysutils/gnomecontrolcenter2' (gnomecontrolcenter2-2.4.0) 
because 'x11-toolkits/eel2' (eel2-2.4.1) failed
--->  Skipping 'x11-toolkits/gtksourceview' (gtksourceview-0.7.0) because 
'graphics/libgnomecanvas' (libgnomecanvas-2.4.0) failed
--->  Skipping 'editors/gedit2' (gedit2-2.4.1) because 'x11-toolkits/
gtksourceview' (gtksourceview-0.7.0) failed
** Listing the failed packages (*:skipped / !:failed)
        ! mail/mutt (mutt-1.4.2.1)      (uninstall error)
        ! devel/libglade2 (libglade2-2.0.1_1)   (configure error)
        * graphics/libgnomecanvas (libgnomecanvas-2.4.0)
        ! x11-toolkits/libwnck (libwnck-2.4.0.1)        (configure error)
        ! editors/openoffice-1.1 (openoffice-1.1.0_1)   (unknown build error)
        ! x11/kdelibs3 (kdelibs-3.1.4_1)        (install error)
        * graphics/kdegraphics3 (kdegraphics-3.1.4)
        * editors/koffice-kde3 (koffice-1.2.1_1,1)
        * x11/kdebase3 (kdebase-3.1.4)
        * misc/kdeutils3 (kdeutils-3.1.4)
        * games/kdegames3 (kdegames-3.1.4)
        * x11-clocks/kdetoys3 (kdetoys-3.1.4)
        * devel/kdesdk3 (kdesdk-3.1.4)
        * devel/kdevelop (kdevelop-2.1.5)
        ! x11-toolkits/gtk-engines2 (gtk-engines2-2.2.0)        (configure 
error)
        ! net/samba (samba-2.2.8a_2)    (uninstall error)
        ! www/mozilla (mozilla-gtk2-1.5_1)      (configure error)
        * x11-wm/metacity (metacity-2.6.3)
        * net/kdenetwork3 (kdenetwork-3.1.4)
        * www/quanta (quanta-3.1.4,2)
        * x11-wm/kdeartwork3 (kdeartwork-3.1.4_1)
        ! sysutils/gconf-editor (gconf-editor-2.4.0,1)  (configure error)
        * deskutils/kdepim3 (kdepim-3.1.4)
        * x11-toolkits/libgnomeprintui (libgnomeprintui-2.4.1)
        * accessibility/gail (gail-1.4.1)
        * graphics/librsvg2 (librsvg2-2.4.0_1)
        * sysutils/kdeadmin3 (kdeadmin-3.1.4_1)
        * multimedia/kdemultimedia3 (kdemultimedia-3.1.4)
        * misc/kdeaddons3 (kdeaddons-3.1.4)
        * x11-toolkits/libbonoboui (libbonoboui-2.4.1)
        * x11-toolkits/libgnomeui (libgnomeui-2.4.0.1_1)
        * x11/gnomedesktop (gnomedesktop-2.4.1.1_1)
        * x11-toolkits/eel2 (eel2-2.4.1)
        * www/libgtkhtml (libgtkhtml-2.4.1_1)
        * www/epiphany (epiphany-1.0.6)
        * x11/gnomepanel (gnomepanel-2.4.1)
        * sysutils/gnomesystemmonitor (gnomesystemmonitor-2.4.0)
        * deskutils/gnomeutils2 (gnomeutils2-2.4.1,1)
        * x11-fm/nautilus2 (nautilus2-2.4.1)
        * sysutils/nautilus-cd-burner (nautilus-cd-burner-0.5.3_3)
        * deskutils/gucharmap (gucharmap-gnome-1.2.0)
        * graphics/eog2 (eog2-2.4.1)
        * graphics/gpdf (gpdf-0.111)
        * print/ggv2 (ggv2-2.4.0.2)
        * archivers/fileroller (fileroller-2.4.2_1,1)
        * sysutils/gnomecontrolcenter2 (gnomecontrolcenter2-2.4.0)
        * x11-toolkits/gtksourceview (gtksourceview-0.7.0)
        * editors/gedit2 (gedit2-2.4.1)
--->  Packages processed: 35 done, 0 ignored, 39 skipped and 9 failed
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to