On Monday 12 April 2004 01:43 pm, Matthew Seaman wrote:
> On Mon, Apr 12, 2004 at 12:39:01PM -0700, Kent Stewart wrote:
>
> [ Upgrading perl... ]
>
> > There is one group that doesn't appear. All of the versions of
> > automake use perl and have the version to use as the 1st line. You
> > need to portupgrade -f automake
> > to get things ready for your new version of perl. FWIW, I am using
> > perl-5.8.2_5
>
> Oh -- good call.  I'll have to remember that for future reference.
> Mind you, specifying the perl version number on the #! line is
> arguably a bug in the port -- if the script needs a minimum perl
> version to work, it should:
>
>    use 5.8.2;
>
> or test the values of $] or $^V
>

I don't think they need a version as much as they specify which version 
they are going to use. I think they work on all versions. The problem 
is that 2 of the 3 specify which version was the default when they were 
built  and I think that is a bug.

Kent

-- 
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to