I've been having this issue with openldap for over a month now and they folks at openldap seem to think this may be a FreeBSD issue. Not sure if it's a general FreeBSD issue or an AMD64 issue so it's going to both.

Can anyone have a look at this and tell me what they think?

Begin forwarded message:

From: Jason Lixfeld <[EMAIL PROTECTED]>
Date: April 17, 2004 12:38:44 AM EDT
To: [EMAIL PROTECTED]
Subject: Call For Assistance #4 - slapd won't die gracefully, multiple versions.


My machine is AMD64. I'm running 5.2.1-RELEASE-p1. I've tried 2.1.29, 2.1.30, 2.2.7, 2.2.8 and 2.2.10 all from FreeBSD ports. no special make options, just plain make. No modifications to the config files, all plain vanilla out-of-the-box configs. I've tried with BDB and LDBM. Same issue with both types of databases. All openldap server versions i have tried exhibit the same problem (this output is from 2.1.29. Output is identicle on all versions, with the exception of the Berkeley DB version in the -d 256 output):

If I start slapd and kill it without issuing a transaction to the server, slapd will die gracefully, no problem:

su-2.05b# /etc/rc.d/slapd start
ps: kvm_getprocs: No such process
Starting slapd.
su-2.05b# ps xa|grep slap
92971 ?? Ss 0:00.01 /usr/local/libexec/slapd -h ldapi://%2fvar%2frun%2fopenldap%2fldapi/ ldap://0.0.0.0/ -u ldap -g ldap
su-2.05b# /etc/rc.d/slapd stop
Stopping slapd.
Waiting for PIDS: 92971.
su-2.05b# ps xa|grep slapd
su-2.05b#


If I start slapd and issue a transaction to the server, slapd will NOT die gracefully. I need to kill -9 it which will do bad things to the database. kill -INT will not work either:

su-2.05b# /usr/local/libexec/slapd -d 256
bdb_initialize: Sleepycat Software: Berkeley DB 4.1.25: (December 19, 2002)
bdb_db_init: Initializing BDB database
slapd starting



conn=0 fd=12 ACCEPT from IP=127.0.0.1:48071 (IP=0.0.0.0:389) conn=0 op=0 BIND dn="" method=128 conn=0 op=0 RESULT tag=97 err=0 text= conn=0 op=1 SRCH base="" scope=0 filter="(objectClass=*)" conn=0 op=1 SRCH attr=namingContexts conn=0 op=1 RESULT tag=101 err=0 text= conn=0 op=2 UNBIND conn=0 fd=12 closed ^Cslapd shutdown: waiting for 0 threads to terminate ^C^C^C^C^C

The transaction I performed was the one from the Quickstart guide here: http://www.openldap.org/doc/admin22/quickstart.html

su-2.05b# ldapsearch -x -b '' -s base '(objectclass=*)' namingContexts
# extended LDIF
#
# LDAPv3
# base <> with scope base
# filter: (objectclass=*)
# requesting: namingContexts
#

#
dn:
namingContexts: dc=my-domain,dc=com

# search result
search: 2
result: 0 Success

# numResponses: 2
# numEntries: 1
su-2.05b#

I've been struggling with this since my first post regarding this issue on March 7th and I still haven't figured it out. I'm asking anyone who may have some experience with OpenLDAP to PLEASE help me sort this out. This has really got me by the balls...

Thanks in advance.


_______________________________________________ [EMAIL PROTECTED] mailing list http://lists.freebsd.org/mailman/listinfo/freebsd-questions To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to