Kevin D. Kinsey, DaleCo, S.P. wrote:
Hi chip,

Please wrap your characters at 80 columns
of so for some of the people who use text
based email.  Thanks!


Sorry about that. My email client is set to wrap lines at 72 chars.


Read on..

mysql.sock is a UNIX socket, created by the mysql process
itself.  If it does not exist, then it's likely that either the
mysql daemon is not running, or it is running without
adequate permissions to create the socket.

If the last is true, then it's possible that mysql is
configured to make the socket somewhere other than
/tmp, because the permissions for /tmp should be such
as to allow the creation of the socket ....

The mysql daemon is started during boot up along with samba and apache. There are no error messages, it appears to start fine.


This is the same message you would receive if
mysqld were not running.  Have you tried this:

% ps -auxv | grep mysql

Did that and got a response that mysqld is running. Then about 10 minutes later did it again and the server was not running. When I tried this to start it manually I resulted in the unable to connect to socket error.
Now this is weird, just after I typed the above paragraph I opened another term and ran the ps command.
I wish I could copy/paste from either eterm or aterm, but it doesn't work. What's really weird is in aterm I do ps -aux | grep mysqld and it returns nothing. In eterm I do the same command and it returns the pid of the mysqd server meaning it is running.


So, it may be running, maybe not, either way, when I try to run mysql from the command line I get the cannot connect to socket error every time.

The permissions on the /temp directory are 777 with the sticky bit set.

Do any messages appear during the
init phase of bootup re: mysql?

No messages about mysql in any startup logs or on the screen. It appears to start normally.


--
Chip

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to