Tsu-Fan Cheng wrote:
>    I just changed a new m/board and found my mouse went crazy, it's out of
> control most of the time and tends to stay in one corner and "shakes"
> itself. it is a generic PS/2 mouse, 2 buttons, no special something, no
> scroller, no nothing. i tried to change "Protocol" in my XF86Config, tried
> "PS/2" "auto" "SysMouse" "IntelliMouse", up to now only "SysMouse" works,

If you run moused(8), the device in XF86Config should be /dev/sysmouse
and the protocol should be set to "SysMouse". I assume you run moused(8)
with something like

  moused_flags="-p /dev/psm0 -t auto"

in your /etc/rc.conf . If so, does the mouse work on the console? If
not, you might want to read psm(4). I had to add


to /boot/device.hints . Note that this is not availeable in FreeBSD 4.x
but instead you will need to add those flags to your kernel config. Find
a line that says

  device psm0 at atkbdc? irq 12

and make it

  device psm0 at atkbdc? irq 12 flags 0x100

Hope this helps, it worked for me.



[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to