Hello everyone,

I am trying to enable the linux swap space I have under Red Hat on FreeBSD 4.9. My disk configuration looks like:

s1 - NTFS
s2 - Windows extended
s3 - ext3
s4 - linux swap

s1 - This is my BSD slice
s2 - NTFS
s3 - ext3
s4 - <none>

So I read the HOWTO on the internet about sharing the swap space; and with it's help I can now swap on the BSD swap space from Linux. However, the HOWTO only says that "FreeBSD can swap on any partition" without saying how to do it.

So I've tried "swapon /dev/ad0s4" from FreeBSD and it always says:
swapon: /dev/ad0s4: Device not configured
I poked around my kernel config file, and changed the NSWAPDEVS variable to 2; still no luck.

I looked in the questions archive from January on, but found no help (albeit not that throughly). Note that I've been using FreeBSD for 4 months without this swap space, without problems. Has anyone else encountered this problem?

Thanks in advance,


Add photos to your e-mail with MSN Premium. Get 2 months FREE* http://join.msn.com/?pgmarket=en-ca&page=byoa/prem&xAPID=1994&DI=1034&SU=http://hotmail.com/enca&HL=Market_MSNIS_Taglines

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to