On Monday 10 May 2004 10:46 am, Bill Moran wrote:
> Kent Stewart wrote:
> > On Monday 10 May 2004 10:23 am, Bill Moran wrote:
> >>This is the weirdest problem I'm seen in a while.
> >>
> >>Client bought a pair of 160G Samsung SP1604N ATA drives.  I'm
> >>supposed to install them in an existing FreeBSD 4.9 system for
> >>additional storage space.
> >>
> >>As soon as the drives are installed, kernel won't boot.  It freezes
> >>up right before the "ad0: ..." messages appear and won't respond to
> >>anything except the reset button. Tried primary slave, secondary
> >>slave ... threw in a Highpoint ATA card and tried every possible
> >>configuration ... no dice.  This was on a relatively new AOpen mobo
> >>with a 2G processor (don't have the model # handy, but I'll get it
> >> if it's important)
> >>
> >>Moved the drives into an older 466mhz system ... same effect ...
> >> boot locks up at the probe message just before it would normally
> >> detect ad0.  In this new system, we even tried removing the
> >> existing drives altogether and starting from scratch on these
> >> drives ... the boot from the CD hangs just like everything else.
> >>
> >>So ... I brought one back to the office to put in a test machine so
> >> I could gather lots of good data, file a PR and get the problem
> >> fixed. Threw it into an old lab machine (266 mhz SOYO board) and
> >> the sucker WORKS PERFECT! (so much for gathering data for a bug
> >> report)
> >>
> >>So ... I'm at a complete loss as to what I should do ... and a
> >> bigger loss on what I should recommend to the client.
> >
> > I don't think it is the drive unless size is considered. There are
> > bios problems when the size goes above 120GB or so. You may be
> > bumping into this problem.If that is the case, a bios upgrade may
> > let you use the HD.
> That's pretty odd, as the only mobo that the drive works with is has
> a bios that's completely unable to understand the drive (the bios
> screen says it's 8G).  Both of the other machines we tried in
> detected the drive size correctly in the bios.
> Are you saying that an older bios that incorrectly detects the drive
> is more likely to work than a newer one that _does_ detect it
> correctly? Scratch that ... _I'm_ the one that's saying it, since
> that's what I'm seeing.

No, I was thinking just the opposite. The 160's aren't supposed to work 
in all of the older bioses. IIRC, you need a larger version of LBA to 
map the drive. The 8GB is a sign of even older bios problems. The only 
time I had the hang problem with booting was when I made the drive 
dangerously dedicated. There are bioses that simply hang at discovery 
time with a DD drive mounted.

I have a 160 Maxtor running in my test machine. There were messages 
about it not working on all systems but it installed without a problem 
on 4-stable. It is also very fast for an IDE. I can do a buildworld 
with an AMD 2400+ in 18 minutes using it for my /usr/obj.

Kent Stewart
Richland, WA

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to