Hello list.

I know this had been discussed quite often, but none of the posting
google offered worked out for me. Please (B)Cc: me as I am not on the list. 

I have a Western Digital WDC WD400AB-00CMB0 40 GB IDE drive hooked in as
pri slave in my system and wish to install FreeBSD on it. This is not my
first install, but it won't work this time (using 5.2.1-R):

I try to partition the drive with fdisk during the installation process.
Everytime I hit "w" to write the changes, the program catches ``sig 11''
(segfault?). Curious thing is: I was able to delete partions but I
cannot create new ones. I tried every option concerning bootsector (boot
mngr, std mbr, none) and the error occures every time.

When I enter the fdisk tool it tells me that the drive geometry
"778545/16/63" is wrong. I don't have a clue where it gets that value.
The BIOS detects the geometry as 19158/16/255. The auto-corrected value
is 4865/255/63 which equals the BIOS-setting when access mode is set to
LBA manually. When I enter the geometry manually with "g", it still
mourns the value 19158/16/255 is not correct and again falls back to
those LBA values.

Important to say: the drive seems to work well on WinXP. I encountered
no problem there.  Using the DEBUG=yes in the installation options menue
revealed some UDMA ICRC ... crap error style messages.
For this I played with UDMA und PIO-mode settings for IDE pri-slave in 
the BIOS. Unfortunately, nothing happens (save the above errors ;).

I hope anyone can help me with this issues which slowly driving me
crazy... Thank you!

Carsten


-- 
Carsten Zimmermann
mailto:[EMAIL PROTECTED]
Tel.: +49-(0)40-98760543

PGP: http://hacksocke.de/public_key.asc

Aegis:Net IT-Dienstleistungen
Postfach 620371
22403 Hamburg
http://www.aegisnet.biz
Info: +49-(0)700-AEGISNET
Fax: +49-(0)40-98760547

Attachment: pgp00000.pgp
Description: PGP signature

Reply via email to