Create your self an windows bootable floppy with the ms/windows
fdisk & format programs. Boot from floppy, run fdisk and delete all
partitions including the NT one. Then create new single msdos fat32
partition and set as primary active partition. Reboot from floppy
then run format on c: drive.  Put FreeBSD install cd in drive and
reboot system to start install.

-----Original Message-----
[mailto:[EMAIL PROTECTED] Behalf Of Carsten
Sent: Monday, May 03, 2004 1:03 PM
To: Malcolm Kay
Subject: Re: Partitioning fails due to drive geometry inconsistency

Thanks for the answers so far.

I tried to use the autocorrected values, of course. But I can't
create a
partition with them (as said: I was able to delete a NTFS partition

When I try to write the partition table, sysinstall / fdisk catches
signal 11. It seems fdisk is not able to write the partition data
the (now autocorrected) drive geometry is (still) not valid.


Am Mon May 03, 2004 at 11:0325PM +0930 schrieb Malcolm Kay:
> On Monday 03 May 2004 18:33, Carsten Zimmermann wrote:
> > Hello list.
> >
> > I know this had been discussed quite often, but none of the
> > google offered worked out for me. Please (B)Cc: me as I am not
on the list.
> >
> > I have a Western Digital WDC WD400AB-00CMB0 40 GB IDE drive
hooked in as
> > pri slave in my system and wish to install FreeBSD on it. This
is not my
> > first install, but it won't work this time (using 5.2.1-R):
> >
> > I try to partition the drive with fdisk during the installation
> > Everytime I hit "w" to write the changes, the program catches
``sig 11''
> > (segfault?). Curious thing is: I was able to delete partions but
> > cannot create new ones. I tried every option concerning
bootsector (boot
> > mngr, std mbr, none) and the error occures every time.
> >
> > When I enter the fdisk tool it tells me that the drive geometry
> > "778545/16/63" is wrong. I don't have a clue where it gets that
> This set of figures would correspond to a disk of 401GB (k=1000)
or 374GB
> (k=1024) -- Clearly not a 40GB drive.
> > The BIOS detects the geometry as 19158/16/255. The
auto-corrected value
> This set corresponds to 40.0Gb (k=1000) so seems to be an
acceptable set of
> numbers except that I understand that the seectors per track can't
exceed 63
> so the this set is unsuitable. In LBA mode it is not necessary
that the
> specified geometry is the same as the physical reality. It is
common to set
> the heads and sectors to maximum values 255/63.
> > is 4865/255/63 which equals the BIOS-setting when access mode is
set to
> > LBA manually. When I enter the geometry manually with "g", it
> Which corresponds to this auto-corrected value and again
> to 40.0GB (k=1000). This looks like the best geometry to use.
> > mourns the value 19158/16/255 is not correct and again falls
back to
> > those LBA values.
> >
> Again the 255 value is too large. Don't try to set your own
geometry; go
> with the auto-corrected value.
> Malcolm

Carsten Zimmermann
Tel.: +49-(0)40-98760543

Aegis:Net IT-Dienstleistungen
Postfach 620371
22403 Hamburg
Info: +49-(0)700-AEGISNET
Fax: +49-(0)40-98760547

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to