Jason Taylor wrote:

I've followed the directions in the handbook for setting up lpd and also installed apsfilter via ports and ran /usr/local/share/apsfilter/SETUP. In general printing is working. For example, a text document from OOo prints just fine. However, when I attempt to print a jpeg file the result is what I can best describe as a blurry negative image. That's not terribly accurate. It's more like it's been converted to only a handful of colors and possibly some colors dropped altogether.

I've tried both the native gs driver and the gimp-print stp driver with the same results. Test pages printed from within the apsfilter setup look great. The problem does not seem to be limited to jpegs in particular. A pdf from a few days ago was also blurred/color reduced/altered. Images printed directly from firefox a week or so ago show the same symptoms. Whether those were jpeg, gif, png, or something else, I'm not certain.

I've ruled out any network issues by copying a few jpeg files over to the server and printing them locally. I've also converted a few from jpeg to ps and back again to rule out imagemagick.

I'm confident that the printer itself is in good order based on the good test pages and it having worked well on a WinXP just prior to having been moved over the the FreeBSD box. I no longer have any Windows machines around to check that it still works on them. :-D

Any tips will be much appreciated.

I'm happy to report that the problem is resolved. I can't really say I figured it out. I didn't do anything differently than yesterday. I looked through the apsfilter SETUP script to see what it does to print a test page, replicated it manually, substituting my own jpg converted to ps. That worked! So I ran through the SETUP script again allowing it to overwrite everything that had been there and now it just works.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to