I got an old machine from a garage sale a couple months ago and have been unable to install any operating system on it. Mainly with errors like isolinux: spec packet failed to locate cd rom device. And with FreeBSD 5.1 i got:

Building the boot loader arguments:
Read Error: 0x01
Could not find Primary Volume Descriptor

Someone on IRC pointed me to a release not for 5.1 about how older SCSI CD-Rom Drives will not work anymore with 5.1 on installs. He also told me that 4.9 might work then. So I downloaded 4.9 and put it in. It booted to the installer unlike pretty much every operating system i've tried. During the installation once i got the the partitioning and anything related to the hard drive i would get an error saying there was no disk detected. The Hard Drive and CD-Rom Drive are both detected on the POST, however. I've been able to pull out a lot of information on whats going on.

Its an Adaptec AHA 2940 W Ultra/Ultra Bios 1.23 SCSI Controller with a Seagate hard drive and a Plextor CD-Rom Drive. The machine is a pentium pro 200mhz with a 3com nic and a Matrox vga card. It only has 1 IDE interface on the motherboard which is missing pins so i have no floppy drive on it.

Hard Drive(Lun:0) - - - SCSI Controller(Lun-7 - - - Plextor CD-Rom Drive(Lun:3).
They are both on different cables. I've verified that both cables work. The Controller does talk to the hard drive also. You can manually format it in the SCSI Controllers bios. So Far i've tried changing the termination from automatic to every option. Turned off bios translation. Turned off Lun Support. Modified the kernel config file to make sure the settings were accurate. Also in tty2 at the end there were a few interesting messages.

(da0:ahc0"0"0"0): MEDIUM ERROR asc:31,0
DEBUG: Add mapping for /dev/cuaa0 to sl10
DEBUG: Add mapping for /dev/cuaa1 to sl10
DEBUG: Unable to open disk cd0
DEBUG: Unable to open disk da0

So i launched a emegency shell in tty4 and did camcontrol devlist. It showed the CD-Rom Drive and the Hard Drive. No SCSI Controller though if one was suppost to be present. It was after this we turned off DOS Translation and Lun Support. Still no go. If someone can help please do. I've spent so much time on this and i can't think of anything else that might work.

- Matt Smith

Express yourself with the new version of MSN Messenger! Download today - it's FREE! http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to