I have a LAN that is on private IP.  It is nat'd to the internet.
The internal LAN domain name is registered.  Our ISP
just forwards the domain name to
our other registered domain name.

In an effort to replace our internal msmail (Yuk!), I have
setup a test server running Freebsd 5.1-release.  It has
qmail installed on it and configured as per lifewith qmail.
It passes all the tests as defined in lifewithqmail.

I have another server (HP9000, running HPUX) that has
djbdns (tinydns, dnscache, etc) setup and servicing my
LAN.  internal host names are resolved just fine.

When (from outlook) I try to send email to [EMAIL PROTECTED],
the mail gets sent out to our ISP.  I have outlook configured properly
with a service for the

I have created a mx record on the HP.  I ran the following:

# ./dnsmx

on the qmail server I ran:

mail# dnsquery -t mx
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1241
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;;, type = MX, class = IN  23h51m37s IN MX  0

both seem to see the mx record.   Seems that qmail can't find it though.
what do I need to set/fix to get qmail to find the mx record ?
the resolv.conf on the qmail server has:


any ideas would be great.  BTW, outside users (on the internet) do not use
our internal
dns server to resolve addresses.


[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to