I have a USR 5610 PCI modem that, for some reason, I cannot get to work under FreeBSD 5.2.1. I just installed 5.2.1 last week. Previously, I used 5.1, but it was on a different computer. The thing is, the modem worked great in that other computer. I switched it over to this computer after buying the computer new a couple of months back.

When I boot the machine, dmesg says it finds the modem at sio0 with irq 18. A line or two later, it says it's moving sio0 to sio4, and it puts something else (presumably the "real" serial port on the back of my PC) into sio0. It complains about irq 18 not being in the pool of irqs, or something like that, and says that this port may not be enabled. If I then take a look in /dev, there are no serial ports (sio0 or sio4) listed, but I do have cuaa0 and cuaa4. (which I've noticed that cuaia4, cuaa4, and cuala4 all disappear if I pull out the modem) When I run pciconf -l -v, it tells me that the modem is still at sio4, even though nothing by that name is in /dev.

I've also tried running a few basic commands on /dev/cuaa4, but with no luck. I ran ppp, set the device, speed, and enabled dns (as per the ppp troubleshooting section of the handbook) and typed term. I got the correct prompt, but when I try to type in 'at' (without the quotes), all I get on the screen is 'a'. Things seem to be one letter behind. If I were to keep typing and do atdt, it would only show atd until I hit enter. If I hit enter a second time, the cursor returns to the beginning of the line with atdt on it, rather than giving me a new line. At this point, I cannot quit. I just have to bring up another terminal and killall ppp.

I've also played around with cu, but with similar results. When I issue cu -l /dev/cuaa4, it says "CONNECT". Then when I try typing the at or atdt commands, it does the same as ppp, and I have to kill it in a similar manner.

I've tried moving PCI cards around, and it gives me different irqs (18, 19, or 20, depending on the slot I put it in), but I always get the same results.

I don't understand why this modem would work perfectly and simply in my old computer, but not in the new one. What could be preventing it from working? Any ideas or suggestions would be great. I've googled around, read the handbook, and I just can't seem to get it going. I think if I could just get a push in the right direction, I'd be okay.

I'm not subscribed to freebsd-questions, though I do watch the group through usenet.

Thanks for your time,
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to