I don't think the problem has anything to do with how you upgrade
your system.
I installed 4.10 from minin.iso  and I have same problem about not
being able
to run perl -MCPAN -e shell command.

Something is wrong with the perl CPAN conf files that are part of
the FBSD system.
Problem may also be in the perl port as well.
Maybe time to send problem report and email the perl port
maintainer.


-----Original Message-----
From: [EMAIL PROTECTED]
[mailto:[EMAIL PROTECTED] Behalf Of Kent
Stewart
Sent: Sunday, June 06, 2004 5:06 PM
To: [EMAIL PROTECTED]
Cc: white vamp
Subject: Re: upgraded perl ... now missing mods that was installed
beforeupgrade

On Sunday 06 June 2004 12:48 pm, white vamp wrote:
> i did a portupgrade -acCrRv -x kde
> and every thing upgraded just fine and now when i goto run perl
> -MCPAN -e shell
> it loads ok but in the shell if i do a install Bundle::CPAN or any
> outhere one it cant seam to find net::ftp
> and also sence i did my portupgrade all of my  perl modules are
> missing now .. that i had installed before the upgrade .. any
ideas
> on how i can get the mods back?? or do i have to figure out all
the
> mods that i had installed previousely and reinstall them??
>
> and thx inadvance for any help on this

I don't think you can upgrade perl to a new level with portupgrade.
You
have to run "use.perl port" after you update perl to a new level.
You
will find all of the p5-* in the old perl links. In addition, some
of
the older automake[s] have the perl version you were running at the
time you installed them as the first line of the script. One these
has
been set, you can run your portupgrade.

Kent

>
> David D.
>
> PS:
>
> Summary of my perl5 (revision 5 version 8 subversion 4)
> configuration:
>
> uname -a
> FreeBSD vampextream.com 4.10-RELEASE FreeBSD 4.10-RELEASE #0: Thu
Jun
>  3 15:24:56 PDT 2004
> [EMAIL PROTECTED]:/usr/obj/usr/src/sys/VAMPEXTREAM i386
>
>
> and my perl ver before was 5.8.2  ( before the upgrade )
>
> PSS:
> an example of of some of my missing mods are
> Text::Iconv
> net::ftp
> Can't locate auto/Compress/Zlib/autosplit.ix
>
> _________________________________________________________________
> Watch the online reality show Mixed Messages with a friend and
enter
> to win a trip to NY
>
http://www.msnmessenger-download.click-url.com/go/onm00200497ave/dir
e
>ct/01/
>
> _______________________________________________
> [EMAIL PROTECTED] mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "[EMAIL PROTECTED]"

--
Kent Stewart
Richland, WA

http://users.owt.com/kstewart/index.html
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to
"[EMAIL PROTECTED]"

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to