has someone got an idea, what I'm doing wrong?

I'm trying to get httptunnel to work via a proxy.
I have observed the following behaviour under FBSD-4.5R as well as
under 5.2.1R, with apache-2.0.48_1 as well as with apache-1.3.22_7
and with httptunnel-3.3 as well as with httptunnel-3.0.5.

Finally, I reduced it to the following setting:
(I tried different options for proxy-buffer size und -timeout without
any effect):

telnet 2023
   htc -F 2023 -P
      httpd (as the proxy and at least my Netscape is happy)
         hts -F 8080

After the connect to htc I get no further reaction from telnet.
I can send a CR to htc, where it simply sits around. All connections
are in state ESTABLISHED, only the one to telnetd does not exist at
that time.

htc waits in a read for reply from the proxy, while hts at the same
time also waits for data from the proxy on the first of two connections.
The proxy has two connections open to either htc and hts, but in
the Log of hts there is only the first of them noted. (htc sent a POST
and a GET and waits now for the reply to the GET. The proxy, however,
sent the GET to hts on the second connection, whereas hts waits
in a read in the first one.)

Only after killing htc the proxy sends its data to hts, which then
in turn opens the connection to telnetd and (after stopping hts)
closes it again.

Has someone out there successfully got such a setting (httptunnel
via a proxy) working?

How do I get httptunnel to get the proxy to forward the data
(POST-request) immediately?

Does anyone now of an alternative to httptunnel?
(I tried htun-0.9.5 but gave up as it's too hard Linux-style.)

Unneccessary to note, but without proxy the connection works fine.

Regards and thanks,
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to