I'm cloning a hard disk on 5.2.1-RELEASE system.  I put the new disk in on the
secondary IDE channel and rebooted.  Using sysinstall, I sliced and
labeled the disk.  I ran newfs on the new partitions and the mounted
them at /mnt.  I then realized that I had made a mistake in my
partitioning (labeling), so I unmounted all the partitions and
relaunched sysinstall to re-label the disk, but now I get an error
saying "Unable to write data to disk adX."  Fdisk won't write to the
disk either.  I reset the channel using atacontrol, but this didn't
help.  To see what would happen, I tried to detach the channel, which
was not the one containing the disk the system was booted to.  The
atacontrol process went into a disk-wait status and I was forced to
reboot the system.  I read a post from about a year ago that seemed to
indicate GEOM might be disallowing me to write the lable.  Does anyone
have any insight into this and how to avoid it in the future?

Thanks,
Nathan

Attachment: pgp73cox3xtj9.pgp
Description: PGP signature

Reply via email to