Hiho! :-)

Yesterday I installed an old Creative Soundblaster AWE32 ISA in my
computer. During boot I noticed that the ata(4) driver attached to the
onboard (cdrom) ide-controller. So I got curious and hooked up my new
dvd-drive (Toshiba M1712) . Worked like a charm (PIO4 only, of course

Then I got *really* curious and hooked up my Maxtor 40GB disk to the
ide-controller, thinking: "this will never ever work".

3 minutes later, I saw, much to my surprise, that it *worked*. The
drive was recognized during boot, I could mount my fat32 partitions and
got a transfer rate of about 3,3mb/s from the drive.

First of all, thanks to Soren, whose great ata driver made that
experiment possible. :-)

Second, can anybody explain *why* it worked? Creative (and Google) claim
that the ide-controller supports cdroms (atapi) only and even if that is
wrong, why does it recognize my 40gb drive (the card was made in 1994)? 

Third, is there any driver that supports the Wavetable/Midi part of the
AWE32? :-)

I'm running FreeBSD 5.2.1-RELEASE-p8.

Thanks in advance! :-)

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to