That probably was what I needed, plus I needed the exact specs on my video card and display (800x600). But someplace in there I mangled the config file, I think. After deleting and re-installing the system (for my 5th time) everything worked fine. I now have Gnome up and running. I'll probable switch to KDE because of it's office software.

Next step is configuiring WiFi Internet access. I access the Internet from all over the country through a WiFi modem. I have several pcmcia WiFi cards. Most are B cards, with one being a G card. But configuring this will wait for a later day...


Lloyd Hayes

URL: E-FAX Number: (208) 248-6590
Web Journal:

Mike wrote:

 I've been following this thread for a few days now, and I kept
hoping someone would give you some useful advice, but I haven't
seen any.  I really dislike posting to email groups, but if you find
this advice useful, feel free to forward it on to -questions, just
please anonymize my name/email address from the post.

Log in as root (configuring X11 (xwindows) requires root permissions)
At the prompt, type in:


This will run a program that will try to autodetect the video card
in your computer.  Assuming it is successful (if it is not, this
process will be significantly harder and more annoying) it will bring
up a grahpical configuration program.  You should see a picture of a
computer connected to a mouse, keyboard, video card, and the video card
connected to a monitor.

At this point, hopefully the mouse will work.  If not, you can navigate
the mouse cursor with the number pad keys for directions.  This keyboard
interface requires a bit of playing around with to understand, and
hopefully you will not need to use it (your mouse will just work).

Once you are able to control the graphical interface, you will be able
to go to the "monitors" tab to "configure monitors".  This procedure
is kind of tricky - there is a lot of buttons and weird controls - you
can ignore all these and just use the pulldown on top and select a
video mode that your monitor supports (likely 1024x768...).  It will
ask you if you want to add this "mode line" or something along those
lines - say yes.

Now use the "quit" button in the graphical program.  It will ask you
if you want to save /usr/X11R6/lib/X86Config file.  Click Ok, it will
ask you about a keyboard file, say Ok as well.

You should be back to a command line prompt.  Now type in

xf86cfg -textmode -xf86config /usr/X11R6/lib/XF86Config

this will run the same program, except in a "text" mode and use the
file that it created the first time through as the starting
configuration.  Everything should already be set up correctly except
for the "Configure Screen" section.  Go there, edit "screen 0", pick
a color depth (depending on how new/old your computer is, it could
be as high as 24 bit, but to be on the safe side you can pick 8 or 16
bit for now and you can always re-reun xf86cfg with the same arguments
to change it later).  Then the next screen will have checkboxes - check
only one for the resolution you want.  To be on the safe side, I would
say pick the 1024x768 , but here again you can experiment.

After clicking "finish" you will be back to the main menu.  Select
'write XF86Config and quit' and agree to everything it asks of you.
Now you should be ready to start xwindows.  This is very similar to
typing "win" at the C:> prompt back in the days of windows 3.0, type:


at the prompt, and xwindows should come up with a graphical display
and a working mouse.

You can always kill xwindows by pressing alt+ctrl+backspace to be
returned to the command line again.  I do not know if you have done
this before or not, but if you have kde installed and want to use it
as your window manager/environment, you should also type

echo startkde > ~/.xinitrc

what this will do is create a file called .xinitrc in your "home" directory
that has the line "startkde" in it (~ means home directory).  When you
type "startx" this file will be read and the commands in it will be

Hope this helps.
 - Mike

On Wed, 16 Jun 2004 22:14:06 -0600, Lloyd Hayes wrote

How are you trying to start X Windows? If you're just expecting it

to start, you're going to end up disappointed.

I was expecting the graphical desktop to start automatically. However I also tried startx, and I played with xdm. Whatever I was doing kept coming up with errors about no screen.

Lloyd Hayes

URL: E-FAX Number: (208) 248-6590
Web Journal:

Matt Navarre wrote:

Lloyd Hayes wrote:

I have been told that the reason that I don't have a graphic desktop yet is because my XFree86 Server is not configured right. I finally downloaded the exact specs on my old laptop from Gateway and plugged them into the configure file. No help.
I tried each of the 4 configure methods from the menu. No good, nor does the graphics menu work any more.
I have attempted to switch from KDE to Gnome, to Windowmaker. Again, no good.

How are you trying to start X Windows? If you're just expecting it to start, you're going to end up disappointed.

To start X you need to either type startx at the command prompt or edit /etc/ttys to start xdm (or kdm or gdm) on the console.

here's the handbook page on configuring xdm to start after boot:

Generally the step in section 5.6.2 is all you need to do, the rest is advanced options that you needn't be concerned with at this point. This info applies to kdm and gdm (KDE Display Manager and Gnome Display Manager, respectively)

To get your desired desktop to start you need to put the command to start it in $HOME/.xinitrc(for startx) or $HOME/.xsession(for xdm). To get KDE started (assuming it's installed) just type
'echo startkde >> .xinitrc' at the prompt. Assuming you're at the text console type 'startx'. KDE should start.

I have tried several other things such as the one below:

# cd /usr/ports/x11/XFree86-4
# make install clean

It then suggests that I 'make reinstall' or 'make deinstall'. I tried reinstall first with it then suggesting that I 'make reinstall' again or 'make deinstall'.

# make deinstall

# cd /usr/ports/x11/XFree86-4
# make install clean

While this seemed to install ok, it was still no help. I'm still stuck with line item commands.

When executing afterwards: XFree86 -configure I get: Fatal Server Error
xf86EnableIO: Failed to open /dev/io for extended I/O

Hmm, are you doing this as root? You need to be. Another alternative, if you have the specs for your monitor and video card, is /usr/X11R6/bin/xf86config. It'll ask you questions about your setup and generate a config file based on what you tell it. Try that, and if you still have problems post your config file and relevant log messages to the list, and we'll try to help.

Log says the same thing.

Any ideas?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to