Hello,
  I dont think the problem is related to releasing the DHCP lease because I have 
Windows XP, SuSE linux and now FreeBSD installed on the computer. I havent had any 
problem with Windows/Linux.
  Here's what I get in dmesg for my network interface:
-----------------------------------------------------------------------------------------------------------

sis0: <NatSemi DP8381[56] 10/100BaseTX> port 0x8c00-0x8cff mem 0xd0008000-0xd0008fff 
irq 11 at device 18.0 on pci0

sis0: Silicon Revision: DP83816A

sis0: Ethernet address: 00:0d:9d:43:e5:b7

miibus0: <MII bus> on sis0

sis0: watchdog timeout

---------------------------------------------------------------------------------------------------------------

  As soon as this is logged while booting the Ethernet LED on my broadband modem goes 
OFF. I tried loading module if_sis0.ko and apm.ko, and the Ethernet LED lights up, but 
when I loaded these modules at startup (/boot/loader.conf) the LED still goes off.
 
When I run dhclient -v I get the following output:
-----------------------------------------------------------------------------------------------

Internet Software Consortium DHCP Client V3.0.1rc12

Copyright 1995-2002 Internet Software Consortium.

All rights reserved.

For info, please visit http://www.isc.org/products/DHCP

Listening on BPF/sis0/00:0d:9d:43:e5:b7

Sending on BPF/sis0/00:0d:9d:43:e5:b7

Listening on BPF/fwe0/02:0d:9d:43:60:7e

Sending on BPF/fwe0/02:0d:9d:43:60:7e

Listening on BPF/wi0/00:02:8a:a9:e1:7a

Sending on BPF/wi0/00:02:8a:a9:e1:7a

Sending on Socket/fallback

-------------------------------------------------------------------------------------------

Ifconfig sis0 gives me

--------------------------------------------------------------------------------------------

sis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500

inet6 fe80::20d:9dff:fe43:e5b7%sis0 prefixlen 64 scopeid 0x3 

inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255

ether 00:0d:9d:43:e5:b7

media: Ethernet autoselect (100baseTX <hw-loopback>)

status: active

----------------------------------------------------------------------------------------------------

I may be completely wrong, but I think some wrong module is getting loaded, which is 
causing this problem. Can you point out how I can debug more, and get this solved???

 

Thanks in advance,

--Nikhil.


 

John Murphy <[EMAIL PROTECTED]> wrote: 

Nikhil Kale wrote: 

>Hello, 
> I have just installed FreeBSD 5.2 on my system. My 
>network card is National Semiconductors DP 83815 which 
>is detected properly for interface sis0. But somehow I 
>cant bring the interface up using DHCP. My machine is 
>a dual boot, and the linux system gets the proper DHCP 
>address. 

man 8 dhclient says: 
The client normally doesn't release the current lease as it is not 
required by the DHCP protocol. Some cable ISPs require their clients 
to notify the server if they wish to release an assigned IP address. 
The -r flag explicitly releases the current lease, and once the lease 
has been released, the client exits. 

So you may need to do whatever is your Linux version of dhclient -r 

The DHCP server has already assigned a lease to Linux which FreeBSD 
knows nothing about. 


> I am new to FreeBSD and am not sure whats happening. 

Welcome. 
You should send technical questions to [EMAIL PROTECTED] 
Where I have CC'd this reply. 

-- 
John. 


  



                
---------------------------------
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to