Apologies for the cross-post - this is mainly a hardware problem, but I've
thrown it into -questions as well in case someone has already seen and fixed
this issue.

I have a Compaq Armada M700 that I used for a firewall.  I've recently
upgraded the memory in it to 320MB (64MB onboard + 256MB).  The machine
detects the memory fine.  The FreeBSD bootloader detects the memory fine.
However, when the kernel boots it only detects 64MB.

What's weird, is that if I stick in a 128MB memory module then the kernel
detects the full amount (192MB) fine.

I realise I can use "options MAXMEM" to manually specify the amount of RAM
in the machine, but it just struck me as rather strange that it detects
192MB fine but not 320MB (particularly since the bootloader sees it all).

This is with FreeBSD 5.2.1.  I've not tried it with 4.x.

Has anyone else encountered this problem (and maybe fixed it) ?

| Chris Smith           | Flick Pest Control           |
| Systems Administrator | Suite G4, Zenith Data Centre |
| p: +61 2 9495 9633    | 821-843 Pacific Highway      |
| f: +61 2 9495 9688    | Chatswood, NSW 2067          |
| e: [EMAIL PROTECTED]   | Australia                    |

Message protected by MailGuard: e-mail anti-virus, anti-spam and content filtering.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to