Hi,

Having recently upgraded my motherboard to a brand new Asus P4V8X-X with
S-ATA and added an S-ATA disk I experience some problems I find kind of
weird.

System is installed on 160MB S-ATA disk ad4 and my previous 160
ATA/UDMA133 is on ad0 mounted as /big. Booting up, dmesg gives me this
confusing message:

atapci1: <VIA 8237 ATA133 controller> port 0xfc00-0xfc0f at device 15.1 on
pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
[...]
ad0: 156334MB <Maxtor 6Y160P0> [317632/16/63] at ata0-master UDMA133
ad4: DMA limited to UDMA33, non-ATA66 cable or device
ad4: 152627MB <ST3160023AS> [310101/16/63] at ata2-master UDMA33

How come FreeBSD kernel thinks my S-ATA disk is only capable of UDMA/33?
The S-ATA disk is connected to the motherboard by it's own S-ATA cable,
thus not the problem of two disks with different speeds on same cable.
Beeing new to S-ATA I may have misunderstood things, but the way I see it,
the S-ATA bus and regular ATA bus is isolated and should not bother
eachofter, right?

Next thing is that I today tried to move ~70GB of data from ad0
(ATA/UDMA133) to ad4 (S-ATA) disk. During the cp process I got these
messages:
Jul  5 15:13:18 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 390440063 of 195220000-195220255 (ad0s1 bn 390440063; cn 24303 tn 196
sn 20) trying PIO mode
Jul  5 15:13:18 <kern.crit> studsboll /kernel: ad0: DMA problem fallback
to PIO mode
Jul  5 15:13:18 <kern.crit> studsboll last message repeated 6 times
Jul  5 15:13:21 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 390440175 of 195220000-195220255 (ad0s1 bn 390440175; cn 24303 tn 198
sn 6) status=59 error=40
Jul  5 15:13:24 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 390440271 of 195220096-195220255 (ad0s1 bn 390440271; cn 24303 tn 199
sn 39) status=59 error=40
Jul  5 15:13:27 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 390440271 of 195220096-195220223 (ad0s1 bn 390440271; cn 24303 tn 199
sn 39) status=59 error=40
Jul  5 16:34:39 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 228774239 of 114387008-114387263 (ad0s1 bn 228774239; cn 14240 tn 137
sn 8) status=59 error=40
Jul  5 16:34:42 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 228774271 of 114387040-114387263 (ad0s1 bn 228774271; cn 14240 tn 137
sn 40) status=59 error=40
Jul  5 16:34:44 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 228774399 of 114387168-114387263 (ad0s1 bn 228774399; cn 14240 tn 139
sn 42) status=59 error=40
Jul  5 16:34:47 <kern.crit> studsboll /kernel: ad0s1e: hard error reading
fsbn 228774399 of 114387168-114387263 (ad0s1 bn 228774399; cn 14240 tn 139
sn 42) status=59 error=40

There are 2 different errors here. First we have a "hard reading error"
and then "DMA problem". The DMA problem, at ad0 (ATA/UDMA133 disk, weird
enough) tells me that I might be wrong about that S-ATA and regular ATA
disk does not bother eachother. Someone please explain this... the disk
has been working 100% fine on my old motherboard afaik.

The "hard reading error" is supposed to be about damaged sectors on the
disk. Is it always like that, or could the errors come from some kind of
bus error, ie same source of problems as the UDMA errors? The disk is
rather new and shouldn't have broken sectors. I suppose.

I'd really like som kind of tip on where to start. At the moment I can't
think of anything that's wrong.

Complete dmesg follows:

Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.10-STABLE #1: Wed Jun  2 21:26:45 CEST 2004
    root@:/usr/obj/usr/src/sys/STUDSBOLL
Timecounter "i8254"  frequency 1193182 Hz
CPU: Intel(R) Celeron(R) CPU 2.80GHz (2799.93-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0xf29  Stepping = 9
 
Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,
MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
real memory  = 536018944 (523456K bytes)
avail memory = 516935680 (504820K bytes)
Preloaded elf kernel "kernel" at 0xc0481000.
Warning: Pentium 4 CPU: PSE disabled
Pentium Pro MTRR support enabled
md0: Malloc disk
Using $PIR table, 10 entries at 0xc00f5a40
npx0: <math processor> on motherboard
npx0: INT 16 interface
pcib0: <Host to PCI bridge> on motherboard
pci0: <PCI bus> on pcib0
agp0: <VIA Generic host to PCI bridge> mem 0xe0000000-0xe3ffffff at device
0.0 on pci0
pcib1: <PCI to PCI bridge (vendor=1106 device=b198)> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
pci1: <ATI model 5964 graphics accelerator> at 0.0 irq 11
pci1: <ATI model 5d44 graphics accelerator> at 0.1
ahc0: <Adaptec 2940 Ultra SCSI adapter> port 0xed00-0xedff mem
0xdfb00000-0xdfb00fff irq 3 at device 11.0 on pci0
aic7880: Ultra Wide Channel A, SCSI Id=7, 16/253 SCBs
xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0xec00-0xec7f mem
0xdfd00000-0xdfd0007f irq 10 at device 13.0 on pci0
xl0: Ethernet address: 00:01:02:fa:84:31
miibus0: <MII bus> on xl0
xlphy0: <3c905C 10/100 internal PHY> on miibus0
xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
atapci0: <VIA 8237 SATA150 controller> port
0xe800-0xe8ff,0xef90-0xef9f,0xefa8-0xefab,0xefa0-0xefa7,0xefac-0xefaf,0xe
fe0-0xefe7 irq 10 at device 15.0 on pci0
ata2: at 0xefe0 on atapci0
ata3: at 0xefa0 on atapci0
atapci1: <VIA 8237 ATA133 controller> port 0xfc00-0xfc0f at device 15.1 on
pci0
ata0: at 0x1f0 irq 14 on atapci1
ata1: at 0x170 irq 15 on atapci1
uhci0: <VIA 83C572 USB controller> port 0xeec0-0xeedf irq 11 at device
16.0 on pci0
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xef00-0xef1f irq 11 at device
16.1 on pci0
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <USB controller> at 16.4 irq 5
isab0: <PCI to ISA bridge (vendor=1106 device=3227)> at device 17.0 on
pci0
isa0: <ISA bus> on isab0
pcm0: <VIA VT8233X> port 0xe000-0xe0ff irq 5 at device 17.5 on pci0
pcm0: <Analog Devices AD1980 AC97 Codec>
pci0: <unknown card> (vendor=0x1106, dev=0x3065) at 18.0 irq 11
orm0: <Option ROMs> at iomem
0xc0000-0xccfff,0xcd000-0xd0fff,0xd1000-0xd17ff,0xd1800-0xd1fff on isa0
pmtimer0 on isa0
fdc0: <NEC 72065B or clone> at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: FIFO enabled, 8 bytes threshold
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> flags 0x1 irq 1 on atkbdc0
kbd0 at atkbd0
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: model IntelliMouse Explorer, device ID 4
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 16550A
sio1: configured irq 3 not in bitmap of probed irqs 0
ppc0: <Parallel port> at port 0x378-0x37f irq 7 on isa0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: IEEE1284 device found /NIBBLE/ECP
Probing for PnP devices on ppbus0:
ppbus0: <HEWLETT-PACKARD DESKJET 950C> MLC,PCL,PML
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
plip0: <PLIP network interface> on ppbus0
IPsec: Initialized Security Association Processing.
IP Filter: v3.4.31 initialized.  Default = block all, Logging = enabled
ad0: 156334MB <Maxtor 6Y160P0> [317632/16/63] at ata0-master UDMA133
ad4: DMA limited to UDMA33, non-ATA66 cable or device
ad4: 152627MB <ST3160023AS> [310101/16/63] at ata2-master UDMA33
Waiting 2 seconds for SCSI devices to settle
Mounting root from ufs:/dev/ad4s1a
cd0 at ahc0 bus 0 target 6 lun 0
cd0: <PIONEER DVD-ROM DVD-305 1.00> Removable CD-ROM SCSI-2 device 
cd0: 20.000MB/s transfers (20.000MHz, offset 15)
cd0: Attempt to query device size failed: NOT READY, Medium not present

Thanks in advance.

Rickard Borgmäster


-- 

Rickard

                                               .--.        .--.
.----------------------------------------.     |  |        |  | .-.
|           Rickard Borgmäster           |     |  |        |  |/  /
|             [EMAIL PROTECTED]             |   .-^  |  .--.  |     <
|         http://doktorn.sub.nu/         |  (  o  | ( () ) |  |\  \
`----------------------------------------'  `-----'  `--'  `--' `--'


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to