Firstly I am fairly new to FreeBSD and I have been
stuck on this for a couple of weeks now.  I am
installing a web server, Resin, that in order to run
ssl connections needs to have openssl compiled with
threads enabled. 

I am running FreeBSD 4.10 Stable, it is brand new
computer with a clean install.  I have gotten Resin
installed and working via the ports. and am now trying
to get it to work with https connections.
When I start resin it gives the error 
"Resin requires a threaded version of OpenSSL. 
OpenSSL must be compiled with OPENSSL_THREADS for
Resin to use it."

So I went to the /usr/ports/security/openssl/
and ran make -DOPENSSL_THREADS; make install; make
restarted (I am from the world of windows) and tried
to start resin, with the same error, so I dont think
it took.

I have tried using -DOPENSSL_OVERWRITE_BASE and that
did not seem to work either.

If I run make, then go into the openssl0.9.6d
directory and run the command ./config threads, It
will not compile at all and gives an error about the
crypto.c file.
The openssl site just says that most OSes have it
built by default with threads enabled, and if it is
not to build it with threads enabled. But I dont know

Anyone know what dumb thing I am doing/not doing so I
can get Openssl built with threads enabled.

Thank you in advance,
Gene Gilbert

Do you Yahoo!?
Take Yahoo! Mail with you! Get it on your mobile phone.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to