I am experiencing a major problem with LRZ on FreeBSD.  I have tried it on FreeBSD 4.7 
and FreeBSD 5.2.1.  I am using LRZ version 0.12.20.  Here's the scenario.
A very large automotive supplier (our client) uses HHP Dolphin 7200 scanners to scan 
their automotive crates.  The scans are batched in the scanners.  When they are ready 
to upload the data to our server, they dock the scanner in the cradle.  The cradle is 
connected to a 56K US Robotics modem.  We wrote the scanner application using 16bit C 
compiler (because the scanners are DOS based).  We're using a Y-Modem protocol to 
upload the data files.  The scanner dials into a modem pool to upload the data.  When 
a connection is established, LRZ is used to receive the data files from the scanner.  
With smaller files (7K and smaller), this works fine.  I've tried uploading a 12K 
file.  After uploading 8K, the scanner returns an NAK error.  This error keeps 
repeating until the scanner gives up and the upload fails.  I've tried a 24K file, it 
fails after 16K.  I've tried a 56K file and it fails at 16K.  NAK error each time.  
I've tried the above scenario on FreeBSD 4.7 and FreeBSD 5.2.1 about 30 times for each 
file size, with the exact same result each time.

I've tried the exact same setup on Linux RH 9 and it works every time.  No problems 
uploading files as big as 100K.

I am a big advocate of FreeBSD.  We currently use it on about 8 servers.  I don't want 
to have to switch to Linux.  However, if that is the only choice that I have, then 
that's the only choice I have.

If I could speak to someone about this issue, or be directed to some help, I would 
really appreciate it.  Please reply to this email and I'll send my toll-free number.  
I would really like to keep using FreeBSD to support all of our applications.  Any 
assistance would be greatly appreciated.
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to