[Note: cross-post removed.  -questions is the appropriate place for this.]

As your rc.conf contents show, you have the same block of addresses assigned
to both interfaces.  This is a broken configuration.  You need to renumber
one of these networks into non-overlapping space.  I would change the
DSL-modem side to use 192.168.0.0/24, then use 192.168.1.0/24 on the LAN.

> From: freebsder <[EMAIL PROTECTED]>
> 
> I have a Freebsd 5.1 box connected to the internet. 
> It works.  But I am now trying to network two other
> Win XP machines as per the following network
> hierarchy:
> 
> <><><>
> Setup
> <><><>
> ISP-> DSL Modem -> FreeBSD box :
> 1) "vr0" 192.168.0.1 [Gateway machine address] 
> 2) "ed0" 192.168.0.3 [Internal Network address]
> connects to:->
> 
> 4- port HUB ->
> 1)WinXP machine #1 192.168.0.2
> 2)Freebsd Box 192.168.0.3
> 3)WinXP machine #2 192.168.0.4
> 
> <><><>
> Problem:
> <><><>
> I cannot communicate to the Internet from WinXP #2 
> (Have not tried to config WinXP #1 yet).
> 
> <><><>
> Browser Config
> <><><>
> IE Brower Settings for WinXP #2 {Tools>Internet
> Options>Connections>)
> -I set the browser so that it never dials a connection
> because it is suppose to be networked right?
> - in the LAN Settings option, I set the Proxyserver
> option with the address of the gateway of 192.168.0.1
> with Port 80
> 
> <><><>
> Dialouge
> <><><>
> >From Freebsd Machine
> # ping 192.168.0.4
> PING 192.168.0.4 (192.168.0.4): 56 data bytes
> ping: sendto: Host is down
> ping: sendto: Host is down
> 
> -at one point I was able to ping the freebsd machine
> from WinXP #2 but then for some reason, I made a
> change and cannot ping anymore...
> 
> <><><>
> RC.CONF
> <><><>
> 
> My rc.conf file looks like this:
>       font8x14="NO"
>       font8x16="swiss-8x16"
>       font8x8="swiss-8x8"
>       inetd_enable="YES"
>       linux_enable="YES"
>       moused_enable="YES"
>       moused_port="/dev/psm0"
>       moused_type="auto"
>       nfs_client_enable="YES"
>       nfs_server_enable="YES"
>       rpcbind_enable="YES"
>       saver="rain"
>       scrnmap="NO"
>       usbd_enable="YES"
>       ifconfig_vr0="DHCP"
>       ifconfig_ed0="DHCP"
> 
> ##initialise NIC
>       network_interfaces="vr0 ed0 lo0 tun0"
>       ifconfig tun0
>       ifconfig vr0= "media 10baseT/UTP up"
>       ifconfig_ed0="inet 192.168.0.3  netmask 255.255.0.0"
>       ifconfig_vr0="inet 192.168.0.1  netmask 255.255.0.0"
>       hostname="myserver"
> 
> ##User ppp configuration
>       ppp_enable="YES"
>       ppp_mode="ddial"
>       ppp_nat="NO"
>       ppp_profile="bellnet"
>       #ppp_user="root"
> 
> ## Firewall
>       gateway_enable="YES"
>       firewall_enable="YES"
>       firewall_type="OPEN"
>       #firewall_quiet="NO"
>       firewall_script="/etc/rc/firewall"
> 
>       natd_enable="YES"
>       natd_interface="vr0"
>       natd_flags="redirect_port tcp 192.168.0.3:80 80"
> 
>       rpc_statd_enable="YES"
>       tcp_extensions="YES"
> 
> ## Mail
> 
>       sendmail_enable="YES"
> 
> <><><><><><><>
> 
> HELP!
> 
> Thanks in advance.


_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to