Christian Schüler wrote:

This problem may be related to the problem reported in this
post:
http://lists.freebsd.org/mailman/htdig/freebsd-questions/2004-June/049088.html

When trying to Autogen a new project, the configure script bails with the
message:

...
./ltconfig: Can't open ./ltconfig: No such file or directory
configure: error: libtool configure failed

I then created an empty ./ltconfig file inside the Project directory.
This fixed the Autogen process, but the build is nevertheless broken.
When I build a wizard generated test project, I get the following message:

../libtool: Can't open ../libtool: No such file or directory

I do believe him that there is no ../libtool. So I tried to change
./ltconfig to contain a line emitting where I have libtool installed, like
so

#!/bin/sh
echo /usr/local/bin

and another version

#!/bin/sh
echo /usr/local/bin/libtool15

however, to no avail. I also tried symlinking libtool to different versions
like libtool13 and libtool15, and also copying a libtool executable to ../
relative to the project directory, nothing works.


Now I am clueless. Has anyone running Anjuta-1.2.2 on FreeBSD? Might be worth noting that I run xFce, not the complete Gnome package.

-chris


Greetings!

I'm the one that posted the original inquiry regarding my libtool problems, and I think you're experiencing a different kind of problem. It seems to me that your Anjuta does not properly create your project. Why this is, I do not know. Did you install Anjuta from ports, or did you download the sources off of its website? If the latter is true, it may be that whatever generates the scripts (or maybe even the scripts themselves) have hardcoded linuxisms in them.

After creating a fresh project (any error messages notwithstanding), what's in the project directory? Could you give an ls of it? And where do you place your project directories? ~/Projects is the default, if I recall correctly. I'm thinking that since the files obviously aren't created it might be a permission problem. Just exhausting the possibilities here. :-)

I did find the solution to my initial problem, by the way. I posted a follow-up in reply to myself, but I guess you've already read that.

-Henrik W Lund
_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to