From: Anish Mistry <[EMAIL PROTECTED]>
Date: Monday, July 19, 2004 2:29 pm

> 
> On Monday 19 July 2004 05:10 pm, [EMAIL PROTECTED] wrote:
> > Aloha
> >
> > I had previously started a thread with this problem and although I
> > received several suggestions the problem was never solved.
> > http://lists.freebsd.org/pipermail/freebsd-questions/2004-
> June/050819.html>
> > Below I have included more information. If I change an 8MB card for
> > another 8MB card everything works as it should. If I try a 
> different size
> > card it fails.
> >
> > In addition, if I boot with no card in the slot, I cannot get a 
> slice to
> > initiate in /dev. i.e. I will see /dev/da0 - /dev/da3. When I 
> boot with
> > a card in the slot I see /dev/da2s1 as seen below. This problem 
> has been
> > reported by others (found through google) but again there was no 
> solution.> Is there a friend that I am unaware of?
> >
> > I have tried various attempts with camcontrol without any good 
> results. If
> > I unplug and replug the USB cable both of the above problems are 
> corrected.> I don't feel that is a viable solution. My wife has 
> WXP on her computer and
> > it will update with the changing of a card. I really need a 
> friend that
> > will rescan or update the USB connection.
> >
> > Here are the related parts of dmesg.boot. da4 is a thumb drive 
> and da1-3
> > are the 4 slots of my card reader. The SmartMedia card is in da2.
> >
> > GEOM: create disk da0 dp=0xc2e44050
> > GEOM: create disk da1 dp=0xc2dacc50
> > GEOM: create disk da2 dp=0xc2e47450
> > GEOM: create disk da3 dp=0xc2e45850
> > GEOM: create disk da4 dp=0xc2e45450
> > da4 at umass-sim1 bus 1 target 0 lun 0
> > da4: <Generic STORAGE DEVICE 1033> Removable Direct Access SCSI-
> 0 device
> > da4: 1.000MB/s transfers
> > da4: 250MB (512000 512 byte sectors: 64H 32S/T 250C)
> > da0 at umass-sim0 bus 0 target 0 lun 0
> > da0: <USB2.0 CardReader CF RW 0814> Removable Direct Access SCSI-
> 0 device
> > da0: 1.000MB/s transfers
> > da0: Attempt to query device size failed: NOT READY, Medium not 
> present> da1 at umass-sim0 bus 0 target 0 lun 1
> > da1: <USB2.0 CardReader SD RW 0814> Removable Direct Access SCSI-
> 0 device
> > da1: 1.000MB/s transfers
> > da1: Attempt to query device size failed: NOT READY, Medium not 
> present> da2 at umass-sim0 bus 0 target 0 lun 2
> > da2: <USB2.0 CardReader SM RW 0814> Removable Direct Access SCSI-
> 0 device
> > da2: 1.000MB/s transfers
> > da2: 7MB (16000 512 byte sectors: 64H 32S/T 7C)
> > da3 at umass-sim0 bus 0 target 0 lun 3
> > da3: <USB2.0 CardReader MS RW 0814> Removable Direct Access SCSI-
> 0 device
> > da3: 1.000MB/s transfers
> > da3: Attempt to query device size failed: NOT READY, Medium not 
> present> (da0:umass-sim0:0:0:0): READ CAPACITY. CDB: 25 0 0 0 0 0 
> 0 0 0 0
> > (da0:umass-sim0:0:0:0): CAM Status: SCSI Status Error
> > (da0:umass-sim0:0:0:0): SCSI Status: Check Condition
> > (da0:umass-sim0:0:0:0): NOT READY asc:3a,0
> > (da0:umass-sim0:0:0:0): Medium not present
> > (da0:umass-sim0:0:0:0): Unretryable error
> > Opened disk da0 -> 6
> > (da0:umass-sim0:0:0:0): READ CAPACITY. CDB: 25 0 0 0 0 0 0 0 0 0
> > (da0:umass-sim0:0:0:0): CAM Status: SCSI Status Error
> > (da0:umass-sim0:0:0:0): SCSI Status: Check Condition
> > (da0:umass-sim0:0:0:0): NOT READY asc:3a,0
> > (da0:umass-sim0:0:0:0): Medium not present
> > (da0:umass-sim0:0:0:0): Unretryable error
> > Opened disk da0 -> 6
> > (da1:umass-sim0:0:0:1): READ CAPACITY. CDB: 25 20 0 0 0 0 0 0 0 0
> > (da1:umass-sim0:0:0:1): CAM Status: SCSI Status Error
> > (da1:umass-sim0:0:0:1): SCSI Status: Check Condition
> > (da1:umass-sim0:0:0:1): NOT READY asc:3a,0
> > (da1:umass-sim0:0:0:1): Medium not present
> > (da1:umass-sim0:0:0:1): Unretryable error
> > Opened disk da1 -> 6
> > (da1:umass-sim0:0:0:1): READ CAPACITY. CDB: 25 20 0 0 0 0 0 0 0 0
> > (da1:umass-sim0:0:0:1): CAM Status: SCSI Status Error
> > (da1:umass-sim0:0:0:1): SCSI Status: Check Condition
> > (da1:umass-sim0:0:0:1): NOT READY asc:3a,0
> > (da1:umass-sim0:0:0:1): Medium not present
> > (da1:umass-sim0:0:0:1): Unretryable error
> > Opened disk da1 -> 6
> > (da3:umass-sim0:0:0:3): READ CAPACITY. CDB: 25 60 0 0 0 0 0 0 0 0
> > (da3:umass-sim0:0:0:3): CAM Status: SCSI Status Error
> > (da3:umass-sim0:0:0:3): SCSI Status: Check Condition
> > (da3:umass-sim0:0:0:3): NOT READY asc:3a,0
> > (da3:umass-sim0:0:0:3): Medium not present
> > (da3:umass-sim0:0:0:3): Unretryable error
> > Opened disk da3 -> 6
> > (da3:umass-sim0:0:0:3): READ CAPACITY. CDB: 25 60 0 0 0 0 0 0 0 0
> > (da3:umass-sim0:0:0:3): CAM Status: SCSI Status Error
> > (da3:umass-sim0:0:0:3): SCSI Status: Check Condition
> > (da3:umass-sim0:0:0:3): NOT READY asc:3a,0
> > (da3:umass-sim0:0:0:3): Medium not present
> > (da3:umass-sim0:0:0:3): Unretryable error
> > Opened disk da3 -> 6
> >
> >
> >
> > %su
> > Password:
> > hp# ls -l /dev/da*
> > crw-r-----  1 root    operator    4,  20 Jul 19 06:19 /dev/da0
> > crw-r-----  1 root    operator    4,  21 Jul 19 06:19 /dev/da1
> > crw-r-----  1 root    operator    4,  22 Jul 19 06:19 /dev/da2
> > crw-rw----  1 robert  robert      4,  25 Jul 19 06:19 /dev/da2s1
> > crw-r-----  1 root    operator    4,  23 Jul 19 06:19 /dev/da3
> > crw-r-----  1 root    operator    4,  24 Jul 19 06:19 /dev/da4
> > crw-rw----  1 robert  robert      4,  26 Jul 19 06:19 /dev/da4s1
> > hp#
> >
> >
> > hp# mount_msdosfs /dev/da2s1 /mnt/olympus
> >
> > hp# ls -l /mnt/olympus/dcim/100olymp
> > total 680
> > -rwxr-xr-x  1 root  wheel  694158 Jul 12 18:27 p7120001.jpg
> > hp#
> > hp# umount /mnt/olympus
> >
> > <here I change the SM card with another 8MB SM card>
> >
> > hp# mount_msdosfs /dev/da2s1 /mnt/olympus
> > hp# ls -l /mnt/olympus/dcim/100olymp
> > total 1352
> > -rwxr-xr-x  1 root  wheel  704002 Jan  1  2000 p1010001.jpg
> > -rwxr-xr-x  1 root  wheel  679720 Jan  1  2000 p1010002.jpg
> > hp#
> > hp# umount /mnt/olympus
> >
> > <then I change it back to the original>
> >
> > hp# mount_msdosfs /dev/da2s1 /mnt/olympus
> > hp# ls -l /mnt/olympus/dcim/100olymp
> > total 680
> > -rwxr-xr-x  1 root  wheel  694158 Jul 12 18:27 p7120001.jpg
> >
> > hp# umount /mnt/olympus
> >
> > <now I insert a 128MB SM card>
> >
> > hp# mount_msdosfs /dev/da2s1 /mnt/olympus
> > mount_msdosfs: /dev/da2s1: Invalid argument
> > hp#
> >
> >
> Have you tried a "camcontrol rescan all" before inserting the new 
> disk?
> - --
I had tried camcontrol rescan 0:0:2 without success
and I just tried camcontrol rescan all without success.

Any other suggestions?? Thanks for the response.
Robert 

_______________________________________________
[EMAIL PROTECTED] mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to