I've recently been having problems with the ports/packages system on a newly installed 4.10-RELEASE FreeBSD machine. Some port/package installations would fail, making it seem that a large proportion of package repositories where out of date, and that only a small number were up to date. I more or less solved the problem, but I'm posting this here as it took quite a lot of fiddling to overcome it, and it took me a while to cop what the actual problem was: a dodgy proxy server between me and the freeBSD repositories.

Some port / package installations would fail with:

fetch: ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/local-distfiles/<name-of-port>: size unknown

If the file were fetched manually, the same "size unknown" warning would be displayed, but fetch would actually go ahead and download the file anyway. If the file were placed in /usr/ports/distfiles, installation would sometimes work. In cases where it didn't, an inspection of the downloaded .tar.gz file with cat showed it to in fact contain a http error response from the proxy server I was using. Fetching the same files from a machine outside the firewall worked perfectly.

I tried a different proxy server in the organisation where I work - it is administered by a different department than the one I was using, and seems to work reliably with fetch.

Does this sound like a reasonable explanation to people? If so, which proxy servers are know to be problematic?

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to