Hi Everyone,

I recently switched from FreeBSD 5.2.1 to 4.10 in the hope that it would
solve my seemingly unsolvable Nvidia driver freeze issue. Alas, it did not.
However, now that I am running FreeBSD 4.10 (and intend to stay with it) I
am having an error when I insert my Prolific TDX MemoDisk 256Mb Flash Memory

When I insert the stick, the following messages are displayed in the log and
on the console that go something like this:

Jul 23 16:20:48 UnixBox /kernel: uhub2: Prolific Technology Inc. USB_HUB,
class 9/0, rev 2.00/0.01, addr 2
Jul 23 16:20:48 UnixBox /kernel: uhub2: 1 port with 0 removable, self
Jul 23 16:20:49 UnixBox /kernel: umass0: Prolific Technology Inc.
USB_Storage, rev 2.00/0.01, addr 3
Jul 23 16:20:49 UnixBox /kernel: da0 at umass-sim0 bus 0 target 0 lun 0
Jul 23 16:20:49 UnixBox /kernel: da0: <TDX MemoDisk PROL> Removable Direct
Access SCSI-0 device
Jul 23 16:20:49 UnixBox /kernel: da0: 650KB/s transfers
Jul 23 16:20:49 UnixBox /kernel: da0: Attempt to query device size failed:
NOT READY, Medium not present

I have jumped to the conclusion (I'm a daring guy) that "NOT READY, Medium
not present" is a sure sign indicator of what the issue is but googling,
searching forums and mailing lists, and extensive man page study sessions
(camcontrol, etc) - which I really don't find hugely entertaining, turned up
very little. There were signs of this problem on devices other than mine but
the fixes for them unfortunately haven't worked for me. Also this device
worked fine with FreeBSD 5.2.1 installed fresh from the box (Although I do
now have my own kernel rolled). I would really appreciate some help if
anyone knows what could be the issue. The flash stick works fine in other
machines so it can't be hardware related. I've tried to include as much
information as possible, but I feel I might be at a bit of a dead end.

An attempt to mount the stick displays this:

[EMAIL PROTECTED]:~$ sudo mount -t msdos /dev/da0 /mnt
msdos: /dev/da0: Device not configured

And the following gets written to the log and console when the above mount
operation is attempted:

Jul 23 17:04:35 UnixBox sudo:    gavin : TTY=ttyv0 ; PWD=/usr/home/gavin ;
USER=root ; COMMAND=/sbin/mount -t msdos -o ro /dev/da0 /mnt
Jul 23 17:04:35 UnixBox /kernel: (da0:umass-sim0:0:0:0): READ CAPACITY. CDB:
25 0 0 0 0 0 0 0 0 0
Jul 23 17:04:35 UnixBox /kernel: (da0:umass-sim0:0:0:0): NOT READY asc:3a,0
Jul 23 17:04:35 UnixBox /kernel: (da0:umass-sim0:0:0:0): Medium not present

Further more, information from dmesg about kernel and USB driver

Copyright (c) 1992-2004 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD 4.10-RELEASE #1: Sun Jul 25 19:41:06 EST 2004
    [EMAIL PROTECTED]:/usr/src/sys/compile/UNIXBOXKERNEL
Timecounter "i8254"  frequency 1193182 Hz
Timecounter "TSC"  frequency 902052412 Hz
CPU: AMD Athlon(tm) Processor (902.05-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x642  Stepping = 2
  AMD Features=0xc0440000<RSVD,AMIE,DSP,3DNow!>
real memory  = 268369920 (262080K bytes)
avail memory = 255545344 (249556K bytes)
Preloaded elf kernel "kernel" at 0xc0573000.
Preloaded elf module "nvidia.ko" at 0xc057309c.
link_elf: symbol linux_ioctl_register_handler undefined

uhci0: <VIA 83C572 USB controller> port 0xc000-0xc01f irq 9 at device 7.2 on
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xc400-0xc41f irq 9 at device 7.3 on
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
pci0: <unknown card> (vendor=0x1106, dev=0x3057) at 7.4
chip1: <VIA 82C686 AC97 Audio> port
0xc800-0xc803,0xcc00-0xcc03,0xd000-0xd0ff irq 10 at device 7.5 on pci0

Many thanks for even bothering to read this far

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to