So I was trying to properly install a new 200G WD HDD on a Highpoint
controller and wasn't having any luck, so I figured I might as well try
getting the USB2 Enclosure working with the machine too while I was at it
(also a 200G drive, but formatted for NTFS), connecting the drive and going
back to seeing where I might have the highpoint controller recognized I
forgot all about the USB drive --- bad mistake.

I went into the /stand/sysinstall under fdisk and saw I had a 200G drive
there, "Oh, I must have done something to enable the HighPoint controller" I
said .. let's edit it .. "Strange, it's reporting NTFS/QNX/..  did I get a
drive with something on it ?"  I was unable to mount the drive with NTFS (it
wasn't in my kernel) so I just said forget it and tried to fdisk, it tossed
a warning about doing the fdisk separately from the disklabel, so I said, ok
, I'll wait.. and went off to do the disklabel at the same time.  at which
point on trying to disklabel the disc I believe the disklabel wrote out
(improperly) and then crashed the PC -- at which point I realized my
mistake.  I don't think that the full write even started because it was a
hard crash and occurred very soon after I executed the command, I don't have
the debug screen that appeared afterward, it was a kernel panic.

This is the USB2 device::

Aug  7 12:14:14 Crappy login: ROOT LOGIN (root) ON ttyv0
Aug  7 12:14:25 Crappy /kernel: umass0: Cypress Semiconductor USB2.0 Storage
Device, rev 2.00/0.01, addr 2
Aug  7 12:14:25 Crappy /kernel: umass0: Get Max Lun not supported (STALLED)
Aug  7 12:14:32 Crappy /kernel: da0 at umass-sim0 bus 0 target 0 lun 0
Aug  7 12:14:32 Crappy /kernel: da0: <WDC WD20 00JB-00FUA0 \0000\0000> Fixed
Direct Access SCSI-0 device
Aug  7 12:14:32 Crappy /kernel: da0: 650KB/s transfers
Aug  7 12:14:32 Crappy /kernel: da0: 190782MB (390721968 512 byte sectors:
64H 32S/T 59710C)

Initially I attempted to just read the disklabel, but it threw a "bad pack
magic number".   So I tried to edit it with disklabel -e , I changed
nothing, but it seems the disklabel was written when I left the editor

Disklabel commands:

[Crappy]:log% disklabel -r /dev/da0
disklabel: bad pack magic number (label is damaged, or pack is unlabeled)

[Crappy]:log% disklabel /dev/da0
# /dev/da0:
type: SCSI
disk: WDC WD20
label: 00JB-00FUA0
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 255
sectors/cylinder: 16065
cylinders: 24321
sectors/unit: 390721968
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # milliseconds
track-to-track seek: 0  # milliseconds
drivedata: 0

8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  c: 390721968        0    unused        0     0        # (Cyl.    0 -


I know it's a 7200 RPM drive, with an 8MB cache and 200G of physical space
( ~ 186GB after formatting in NTFS), the Western Digital Special Edition
200G drive.

I want to restore my data, but I am scared to change the disklabel at the
thought of losing the 150+G of data that is on the drive.  Can anyone PLEASE
provide details on how I might be able to restore my data, right now I can't
mount it anywhere?   Any help is appreciated.

Thank you,

Bryant Eadon

Dual Electrical and Computer Systems Engineering Major
Rensselaer Polytechnic Institute
Lambda Chi Alpha EH1063

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to