On a whim, I decided to try out vinum this afternoon, but found myself stuck
early on. One of the first steps is to locate the partition you want to use
vinum and change it's type from "4.2BSD" to "vinum". This is where I get
stuck, because when I run bsdlabel on the 10GB disk, I get:

[apex:~]# bsdlabel ad0s1
# /dev/ad0s1:
8 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  a:   524288       63    4.2BSD        0     0     0
  b:  1536000   524351      swap
  c: 20044017       63    unused        0     0         # "raw" part, don't edit
  e:   524288  2060351    4.2BSD        0     0     0
  f:   524288  2584639    4.2BSD        0     0     0
  g: 16935153  3108927    4.2BSD        0     0     0
partition c: partition extends past end of unit
bsdlabel: partition c doesn't start at 0!
bsdlabel: An incorrect partition c may cause problems for standard system
partition g: partition extends past end of unit

These errors prevent me changing the fstype to vinum because bsdlabel
apparently takes exception to the sizes and offsets of the partitions and
refuses to apply them.

This system has been running various releases in the 5.x branch for the last 2
years with no problems whatsoever and is currently on 5.2.1-p3.

What looks the funniest is that the 'a' and 'c' partitions don't start at 0.
Every other example of bsdlabel output that I've seen today had those two
starting at 0, and the error message specifically confirms that this isn't
correct. I've tried relabeling the disk with the sysinstall utility on both
4.10 and 5.1 CDs, and on both IDE and SCSI drives to no avail. They all want
to start the partitions at offset 63.

I'm quite at a loss here, and I'm not sure exactly how to proceed. Any help at
all would be appreciated.

Charles Ulrich
System Administrator
Ideal Solution -
[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to