Ciprian Badescu wrote:


Search for or and make a symblic link from to that file. It's an ugly trick, but should work.

Ciprian Badescu

On Thu, 19 Aug 2004, Owen Gardiner wrote:

Date: Thu, 19 Aug 2004 16:35:26 +0200
From: Owen Gardiner <[EMAIL PROTECTED]>
Subject: KDEInit could not launch 'kmail'

I've installed KDE 3.23 on a machine running 5.21-release-p9 which has
x116.7 from X.ORG installed.

I try to start kmail and get a message window of:
"KDEInit could not launch 'kmail'"

If I copy the command properties of the kmail icon and run it from the
command line:

kmail -caption "%c" %i %m

I get the reply:

/libexec/ld-elf.so1: Shared object "" not found

Ditto when trying to run "kedit"
from the command like I get:
/libexec/ld-elf.so1: Shared object "" not found

Everything on the machine has been installed from "ports".

I've tried to do portupgrades and pkgdb -uf and portsdb-Uu but apart
from seeing that some packages are ignores, some are skipped and one
fails I'm none the wiser.

I've reinstalled kde to see if I've managed to do some harm whilst using
  pkgdb -F.  I "may" have wrongly answered some questions about "stale
dependencies" when using it.


Thanks in anticipation.


P.S. I've searched the freebsd mail archives to no avail.


There's LOTS of files not found. I don't understand it as I've tried a
portupgrade  I have made 20 or so links so far.  I'll try portupgrade
with a few more switches thrown in for good measure as I can now see
which port needs upgrading (kdelibs-323_1)!

Trying portupgrade -k and it seems to be doing the trick. I wonder why it failed or skipped the kde* ports without the "-k" switch.



[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to