I have just brought this KVM switch:

But Im having major problems with getting the mouse to work under FreeBSD. Even the keyboard does not work sometimes. This KVM switch has support for hotkey and also supports emulation on both mouse and keyboard.

When I boot up my system and see the BIOS on the computer the keyboard works just fine. Then when it continues to boot and comes to the loader, it still works. And the it starts to load the kernel. But then when i get to the login prompt the keyboard does not work.

And sometimes even thought I stay with the computer the hole boot process I can't even use the keyboard. So I have to use ssh to login to the computer and make it reboot to regain the keyboard. I have also tried to change the cables but I get the same results. And It works with no problems under Windows XP Pro.

The system that im using is FreeBSD 5.2.1-p9, at least on this system.

I have also two other computers that Im running FreeBSD-stable on. On one of my FreeBSD-stable machines I have hade a working mouse under X Windows System (Xorg latest from ports).

But then I rebooted the system and when I started xdm, it found the mouse but when I move it around It didn't move like it should. It took some seconds before it moved and it did not move like it should, jumps several ramdom cm/inches on the screen (Perhaps in the direction that I move the mouse im not sure). Its on usable in other words.

I have also tryied to use moused under FreeBSD but I get the same fault/problem. I also have a problem if I do not have this machine selected when I boot. Then when I switch to it when the boot of the FreeBSD system has complete, The screen on the monitor just blinks.

Still the keyboard works because I can press two times Left Ctrl and then 1 to 4 to change the computer Im controlling. This I can not do with the FreeBSD 5.2.1-p9 system I can only see the screen but have to change the computer im controlling by pressing the button on the switch box.

I have tried to remove the cables and put them back again. But that does not help, the only solution I can see is to reboot the system and let it boot with it selected. I have also booted up with the mouse directly connected to the computer. Then when the system boot was completed I moved the mouse around to see that it did work. After that I plugged back the cable from the switch in to the computers mouse port. And the plugged the mouse back in the switch box, that did not work either.

I have also added flags to both psm0 and atkbd in my kernel config:

# atkbdc0 controls both the keyboard and the PS/2 mouse
device          atkbdc0 at isa? port IO_KBD
device          atkbd0  at atkbdc? irq 1 flags 0x0
device          psm0    at atkbdc? irq 12 flags 0x0

I have also tried with the flags set to 0x100 on both atkbd0 and psm0, but that doesn't seem to make any diffrance. I have done this on my FreeBSD 5.2.1-p9 box as well. I have also changed it in:


But I don't get it working correctly either by that.

Does anybody have a clue or have hade any similar problems and/or who could shine some light on this problem?

Mvh Mattias Björk
ps: sorry if this is posted one time already... I have hade some problems with my MUA.

[EMAIL PROTECTED] mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to